Site Feedback Thread

27 posts

Visual Studio Achievements Not Unlocking Properly

Back to Forum: Site Feedback
  • Digital_V31

    @Maddus Mattus:

    Here was the real fix

    open cmd

    reg add HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\VSAchievements /f /v User /d NinerName_With_Underscore

    YAY!

  • Duncanma

    @Digital_V31: and... we just fixed the underlying issue by releasing v1.1 of the extension, instructions on how to update are posted here:

    http://channel9.msdn.com/Blogs/C9Team/Announcing-Visual-Studio-Achievements#c634630332129844374

    Glad you got it working though!!!

  • Adil666

    None of these solutions work for me. The registry keys were always created correctly, and I have no special characters in my user id. When I get to: "4. Go to Tools --> Options --> VS Achievements and click the Change User button" The first time this worked, although I was not prompted to log in, just to authorize the extension again. If I click "Sign Out" to try and sign in again, nothing happens and the Authorize screen just gets refreshed. The second time, I tried this and all subsequent times, VS crashes completely, and restarts. On restart I am prompted with the Authorize screen again. No combination, of uninstalling the extension, click authorize/ no way, uninstall/ reinstall etc get the extension working. When I build my solutions the same prompts saying an Achievement(s) have been unlocked, but they don't actually get unlocked.

  • Adil666

    Well, I managed to get it working, I had tried installing the plugin on 2 separate PC's with the same problem. Looking at my Live profile, the add on did not show in my authorized apps for some reason. What eventually fixed it, was doing a clean install of VS2010 on a new install of windows, then adding the plugin, signing in and authorizing the add on. Now it works on all of the PC's.

  • Kiranmayee17

    I did all the steps listed above, it still does not work. It identifies the unlocked objects, but not update them on the server.

  • IDS
  • IDS

    Ok, found out that this liveID is just not working. My other account works Smiley Or maybe re-register helped me. I needed to hardly remove the VSAchievements entry from the registry to switch my credentials, unistall->install did not remove my credentials from reg.

    Anyway.. I won't be using this LiveID anymore though...

  • SCHROEFJES

    I'm stuck @ 20 points... New achievements get unlocked @ visual studio but are not reflected on channel9. Every time I restart vs, the achievements popup again. This cannot be the proxy problem because i did got some achievement in the first place, but now it seems dead.

  • MarcWallace

    Did anyone get this working. Mine is all set up properly, regkey appears to be set correctly nothing persisting through to the website. Frustrating as a good idea.

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.