Site Feedback Thread

41 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

When will the buggy comment control be fixed ?

Back to Forum: Site Feedback
  • User profile image
    Mr Crash

    By comment control i mean the edit control with the toolbar you write a comment in.

     

    It's very buggy.

    It seems to only and barely work in internet explorer.

    It sometimes shows up and work in other browsers.

    The browsers spell checking doesn't even work in it.

    Long comments have a bad scroll bug, when you click on a place to edit it scrolls up to the beginning of the comment control.

    And due to this scroll bug you can't even click the submit button because when you try  to click the button it scrolls up.

     

    I use SRware Iron (Chrome version) and i would very much like this to get fixed.

    Why is it taking so much time to fix it ?

    Have you even started to fix it ?

    Do you not care about users that use other (better) browsers ?

     

    Seems like you are not following the browser standards again, that is why it only works in internet explorer...

  • User profile image
    Mr Crash

    Here is a screenshot of the control when it doesn't work correctly: http://i54.tinypic.com/fatny8.png

  • User profile image
    wkempf

    They're using a third party control here. It used to be Telerik, but now I believe they are using TinyMCE.

  • User profile image
    Mr Crash

    hmm..

    http://tinymce.moxiecode.com/tryit/full.php

    have the same or similar scroll bug

  • User profile image
    Cara9

    Yes, we care! Smiley We've been in contact with TinyMCE and are trying on our own to make it work with IE9 RC. It's quite a task from what I understand (I'm not working on it personally) but we are as bothered as you that it isn't working. Part of the problem is that it IS a third party control and we're trying to figure out if we should fix it on our own or if there is an update coming. We got IE9 RC at the same time as everyone else so we're working hard to fix bugs as we see them.

    Most of the complaints that I've heard are that it doesn't work well in IE9 RC (which I can verify as that is what I'm using right now and it's focusing all over the darn place while I'm typing!) and was also buggy in Beta. There's also an annoying "feature" in Chrome where it expands the height of the box in strange ways. If you could let us know what other browsers (and version) it is being buggy in, that would help.

  • User profile image
    Mr Crash

    There's also an annoying "feature" in Chrome where it expands the height of the box in strange ways.

    Actually i like that feature since many website use fixed micro-sized edit boxes that you can barely type a sentence in without scrolling Sad

     

    If you could let us know what other browsers (and version) it is being buggy in, that would help.

    Internet Explorer 8

    SRWare Icon 9.0.600.2 (74100) http://www.srware.net/forum/viewtopic.php?f=18&t=2190 ( i'm using the portable version, I'd like to see that feature in IE9  )

    Firefox latest official version 3.6.1.3

  • User profile image
    spivonious

    @Cara9: I experience the same strange focus issues in both IE9RC (Win7 x64) and IE8 (WinXP SP3). Always reproducible: 1. Type some text. 2. Use the mouse to highlight the text. 3. Press the Backspace key. Instead of the textbox having focus and removing the text, IE has focus and wants to go back to the previous page.

  • User profile image
    Cara9

    @Mr Crash: Yeah, the box height thing isn't something we'll probably fix/change at least any time soon since it doesn't prevent people from using the site. The focus issue is for sure what we're trying to fix. You're the first I've heard with any issues in Firefox though - what happens in the latest official version for you? Is it the focus issue like IE9 RC?

     

    @spivonious: Yep, exactly what I saw earlier on IE9 RC.

  • User profile image
    magicalclick

    there is once when I type first word and press space, the "Praragrah" dropbox will always expend. The way I fixed it by click reply instead of space (adding @someone:). And re-type whatever I was trying to say.

    Leaving WM on 5/2018 if no apps, no dedicated billboards where I drive, no Store name.
    Last modified
  • User profile image
    Mr Crash

    Screenshots of firefox bugs:

    first half of the text misssing ( scrolled to the right, cannot scroll to the left as the D's tries to demonstrate)
    http://i56.tinypic.com/2vim25l.png

    missing toolbar / comment control totally broken == Lost text formatting:

    http://i52.tinypic.com/fe3zno.png

     

    There's also a bug where the submit button refuses to work
    Firefox also have the "missing toolbar", "broken spell checker", "broken reply link", etc... bugs as chrome.

     

    @CaraCara9 "We've been in contact with TinyMCE"
    Not to be mean but i have to mention that it have been weeks (months?)
    So is this just PR talk, saying you've been in contact with x when in fact you have not ?
    I mean reporting bugs doesn't take weeks just an hour per bug and getting in contact with a dev, perhaps 2 days to a week.

     

    So you can understand my skepticism.
    I'm a dev myself and it just doesn't take this long.
    ( As long as you make it clear that corporate / political etc. pissing matches are not tolerated -.- oh the crap some people think they can pull )

  • User profile image
    Cara9

    @Mr Crash: I'm not positive but I think maybe the javascript isn't loading correctly when the control is "totally broken" (missing the controls at the top). If you do a hard refresh (hold down shift and click refresh) on the page, do the controls eventually show up sometimes or are they always gone?

    The control works like this - we put a normal <textbox /> in the source and apply a class to it. There is a javascript that runs on page load that goes and looks for textboxes with that particular class attached to them and then initializes the TinyMCE control. The TinyMCE code hides the original textbox and spawns a bunch of new html including a table containing the toolbar and an iframe which is where you actually end up typing into. The first image you posted makes me think there is somehow a negative css margin being applied to the content inside the iframe.  The second image makes me think the javascript never loaded that makes all the TinyMCE "magic" happen. In Firefox, if you right-click on the textbox when there is no toolbar (ie: "totally broken")  and click "Inspect Element", my guess is that it is just the normal <textbox />. Otherwise, you'd see an <html /> element inside an <iframe />.
    When I said we've been in contact with TinyMCE, that probably did sound vague but not because I'm trying to be political but because I'm not the particular developer who contacted them or have been working on it Smiley I remember Geoff mentioning he had either emailed someone at TinyMCE or filed a bug but I'm not sure what the outcome was. I just replied to you because he was on break for the week and I didn't want you to think the problem was being ignored.

    Anyway, the other day after we spoke about this, I downloaded a new, untouched version of TinyMCE and I did not see the strange focus issues in IE9 out of the box that we are seeing on our site so I tend to think the problem is on our side somewhere. Could be a stylesheet issue, could be some of our other javascript not playing nicely. We have a "theme" that is being applied which contains our C9 emoticons and who knows what else that may be causing the issue as well. Geoff, who just got back from a lovely break, is working on it as we speak and I think he may have less hair now than when he started Wink

    Can you do me a favor and look at the example on the TinyMCE site (link below) in Firefox and IE and tell me if you're having any of the same problems with those examples? I'm mostly curious about the negative margin and no toolbar issue that you posted the images about since I haven't heard of anyone else having those issues.

    http://tinymce.moxiecode.com/tryit/jquery_plugin.php

  • User profile image
    Cara9

    , Mr Crash wrote

    ... snip ...

    There's also a bug where the submit button refuses to work
    Firefox also have the "missing toolbar", "broken spell checker", "broken reply link", etc... bugs as chrome.

    ...snip...

    Forgot about this part. The submit button refuses to work? I haven't heard of this happening... we're not doing any funny business with the submit button besides validation.. you're not getting any error messages when this happens? Any consistencies you can mention when it happens? Always in Firefox and not IE?

    Broken spell checker - We don't have a spell checker on the control that I know of so it must be the Firefox spell checker you're referring to? In what way is it broken?

    Broken reply link - You click, it does nothing? That functionality is done with javascript so maybe it's another case of the javascript not loading properly especially if it's an intermittent problem. Sounds like it's often enough to make you notice though.

  • User profile image
    Cara9

    A fix was pushed up yesterday for the control which should get rid of the focus bugs that were happening in IE. We have removed the dropdown that was grabbing focus away from the textbox because it seemed unnecessary anyway. Please let us know if any of you are still having issues with the control and if so, do you still see that Format dropdown list in the toolbar?

  • User profile image
    magicalclick

    -Post was accidentally deleted while troubleshooting TinyMCE.

    sorry Sad

    -Geoff

    Leaving WM on 5/2018 if no apps, no dedicated billboards where I drive, no Store name.
    Last modified
  • User profile image
    dentaku

    Aha. I just noticed that I can finally type here without the FORMAT dropdown popping up all the time in IE8.

    I still wish the Google Toolbar spellchecker worked in these textboxes. C9 is the only forum I've used that doesn't work with it.

  • User profile image
    Geoffreyk

    , dentaku wrote

    Aha. I just noticed that I can finally type here without the FORMAT dropdown popping up all the time in IE8.

    I still wish the Google Toolbar spellchecker worked in these textboxes. C9 is the only forum I've used that doesn't work with it.

    Wondering if this is a problem with our implementation or a tinyMCE problem. Could you see if you are experiencing the same problem on the tinyMCE demo page?

    Thanks

  • User profile image
    magicalclick

    @Geoffreyk:

     

    Hmm.... amazingly the demo page has no problem at all. And it doesn't have the current problem as well. When you click below end of your text, the cursor sets to the end of your text, which is expected behavior.

     

    Couldn't we just copy the whole thing from demo page and call it a day? 

     

    Add: and when you copy the whole thing, be sure to double check no class name conflicting with other class name, because your CSS may be doing funny stuff to their class.

    Leaving WM on 5/2018 if no apps, no dedicated billboards where I drive, no Store name.
    Last modified
  • User profile image
    Geoffreyk

    , magicalclick wrote

    @Geoffreyk:

    Hmm.... amazingly the demo page has no problem at all. And it doesn't have the current problem as well. When you click below end of your text, the cursor sets to the end of your text, which is expected behavior.

    Couldn't we just copy the whole thing from demo page and call it a day? 

    Add: and when you copy the whole thing, be sure to double check no class name conflicting with other class name, because your CSS may be doing funny stuff to their class.

    I am not sure what problem you are seeing.

    (Probably because I overwrote your post late last night. Still trying to revive it)

    The problem you are having now can be repro'ed like this:

    • empty editing area
    • type a partial line of text
    • use mouse to click the empty space in the editing area below the text you just typed
    • Demo site: cursor moves to the end of the line you just typed or into the line you just typed, directly above where you clicked?
    • CH9: Cursor does what?

    Other than this issue, are you having other issues as well?

    Also, what browser/OS are you using. I would like to try and get a good repro that I can test on.

     

     

    Thanks

    -Geoff

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.