Tech Off Thread

4 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

WinFX CTP: Black Application Window

Back to Forum: Tech Off
  • User profile image
    Tyler Brown

    I really hate writing posts late at night as they always seem to drift onto the second page by the time anyone with answers comes online, but I do my best thinking in the earliest hours of the morning, and thats when I run into problems...

    Anyways, I've got the December CTP of WinFX installed on my system. I originally had the incorrect installation order (VS before WinFX RTC) but I've uninstalled everything and reinstalled in the correct order. The problem now? Whenever I compile a simple WinFX application, the entire window area of the application is black. The border and title bar are the normal Windows XP border/title bar, but the content is just a black rectangle.

    Also, if I get application crashes immediately after compilation if I throw a single ProgressBar object into a DockPanel. When I run the debugger, the problem seems to be caused by the BorderThickness property having a value of "Auto, 1, 1, 1" but I never set that property, so I'm assuming that this has something to do with Cider being thrown into this CTP.

    Anyone else experienced this problem and found a work-around? I've searched the web a bit but the only thing I could find was a comment made to a blog post asking about this for the November CTP, but no answer was given from what I've seen. It'd be a shame if there were no work-around for this, as it means that I'm essentially out of commission for WPF development until the next CTP... unless I install the previous CTP release.

    Just a little extra piece of information: XAML Pad runs perfectly fine. It displays all the WPF content, and I can throw any control into it and it doesn't complain.

  • User profile image
    Tyler Brown

    Something that I just noticed... XAML Pad ceases to work if I close it and then open it back up, or if I start Visual Studio 2005 first and then proceed to open XAML Pad. A reboot of the system solves the problem... until I open up Visual Studio 2005 or restart XAML Pad.

    Kind of an odd problem... I've got the latest drivers installed for my video card.

  • User profile image
    andokai

    Tyler, I'm afraid I have no answer to your problem as such. A post on the MSDN Forums mentions the same problem and in the replies MS acknowledge they are aware of it and that it will be fixed in future versions. Additionally someone suggests a work around which while not perfect allows them to continue working.

  • User profile image
    Tyler Brown

    Thanks for the link andokai. I see that a representative from Microsoft has nailed down the problem and fixed it, but as the post was made on December 20th, I'll have to wait until the next CTP. The problem was that the bits were using an SSE2 instruction executing on non SSE2 hardware.

    The odd thing is, I never had this problem when running the November CTP. The only difference between the December CTP and November CTP for me is that I ran the November CTP on Server 2003 SP1, and I am now running the December CTP on XP SP2. Other than that, its the exact same hardware...

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.