Tech Off Thread

7 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

Unable to start debugging on asp.net web app project! Help!

Back to Forum: Tech Off
  • User profile image
    chuawenching

    Hi there,

    2 questions:

    1)

    I had visual studio .net 2003 ea and it works entirely fine. No debugging errors.

    After i install visual web developer express 2005, i can't able to debug my visual studio .net 2003 asp.net web app projects anymore?

    By uninstalling visual web developer, will it help?

    Do i need to do other configurations? I hope i do not need to reinstall vs.net 2003.

    I had also tried aspnet_regiis -i in the vs.net command prompt, but still fail to work.

    2)

    I am not good in asp.net and looking for learn asp.net. Do you think you recommend me to learn asp.net 1.1 first or go directly to asp.net 2.0 ?

    Can all the tutorials on the internet based on asp.net 1.1 be run on asp.net 2.0 and visual web develop express?

    Thanks.

  • User profile image
    qwert231

    I've had that error where all of a sudden your play button doesn't work in VS 2k3. Try doing this:
    1. Tools
    2. Debug Processes
    3. Attach to the aspnet_wp.exe process.

    It's not nice, but it usually works. I haven't spent the time to work this out. It's a pain and really stupid that you lose the ability to just start your app. The help file doesn't really help.

    If you want to fix it, you need to go through all the files and folders that need permissions and fix the permissions.

    (Yes, I am sure I will be corrected. In fact I hope so, this problem bugs me.)

  • User profile image
    Dan

    To answer your first question, Min Park has written a really detailed walkthrough of what the issues could be for setting up application debugging that should be helpful.

    For your second question, the ASP.NET 2.0 Guided Tour is a great starting place, and the ASP.NET 2.0 QuickStarts are another good resource.

    Hope this helps,
    -Dan

  • User profile image
    AndyD

    I had exactly the same problem, and seeing as my job is a lot of ASP.Net programming I needed to debug. I uninstalled Visual Web Developer Express and Dev Studio 2003 was fine after that.

  • User profile image
    chuawenching

    Thanks. I will check out those website.

    I had uninstall the vs web developer express, but still cannot work with my current vs.net 2003 ea.

    I hope it works. Smiley

    Thanks again.

  • User profile image
    chuawenching

    Well thanks Bill Q for the tips.

    I just notice one thing, you right click the default website in IIS, you can select ASP.NET tab, and select version.

    Amazing!

    And no wonder my iis is pointing at asp.net 2.0 ++, no wonder it can't work in vs.net 2003 ea.

    Wow.. finally fix it! Thanks a lot.. Smiley

  • User profile image
    MrMilney

    chuawenching wrote:
    Well thanks Bill Q for the tips.

    I just notice one thing, you right click the default website in IIS, you can select ASP.NET tab, and select version.

    Amazing!

    And no wonder my iis is pointing at asp.net 2.0 ++, no wonder it can't work in vs.net 2003 ea.

    Wow.. finally fix it! Thanks a lot.. Smiley


    Thanks to both of you for helping me resolve the same issue on my machine. Nice catch, chuawenching!

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.