Not quite as extreme, however since I've installed IE7 beta 3, I now can't access an internal website which is run on IIS6. I got out the old packet sniffer and discovered that IE7 doesn't actually respond to the authentication header it gets sent back:

Content-Length: 1656
Content-Type: text/html
Server: Microsoft-IIS/6.0
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
WWW-Authenticate: Digest qop="auth",algorithm=MD5-sess,nonce="b17fbc9d519fc601a0d32aaa756f038f4de198e74354a9eedebece9093aa565210da5653a1d933f2",charset=utf-8,realm="Digest"
X-Powered-By: ASP.NET
Date: Tue, 04 Jul 2006 10:07:11 GMT

And so IE7 just says it can't find the server (I think it's being creative with the truth).

Also since I installed, my valued Photoshop 6 now hangs at startup.

Why don't you just uninstall you winging pom, I hear you cry! Well, I tried this, restarted the machine (no errors or anything) and was left with an IE6 that was broken, continously complaining about a preview.dlg. I tried a restore point but for some reason the restore point system still gives me IE7.

Help! Any suggestions? Can I force IE6 back over the top without having to do a complete re-install?