Tech Off Post

Single Post Permalink

View Thread: Side-by-side screwup
  • User profile image

    So, I had the same problem as above.  I had developed a dll using Qt that worked fine on my machine but would not register on another.  The familiar "This application has failed to start because the application configuration is incorrect..." appears when I ran the depencency walker on the dll.

    So this was the solution that worked for me, which may help some others see what's going wrong here:

    Within my dll the manifest emedded read:

    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
          <assemblyIdentity type="win32" name="Microsoft.VC80.DebugCRT" version="8.0.50608.0" processorArchitecture="x86" publicKeyToken="1fc8b3b9a1e18e3b"></assemblyIdentity>

    It seemed that the assembly definition was not found upon my client computer.  So then, from within my original computer's 'Windows\WinSxS' directory, I copied the 'x86_Microsoft.VC80.DebugCRT_1f...' directory and it's associated files within the 'Policies' and 'Manifests' directories onto the client computer.  Once copied, the dll registrered fine. 

    Hope this helps...