Tech Off Thread

10 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

.NET Framework 1.1 SP1 and Welcome Screen Log-On

Back to Forum: Tech Off
  • User profile image
    RobertB

    Good evening.  Recently downloaded and installed the .NET Framework 1.1  SP1.  Now we do not get the Welcome Screen Log-On -- just a dialog box, "Unlock Computer." Asks for Xpuser Name and password. Does anyone know how to get rid of that and get the Welcome Screen Log-On back on like it was, short of going through System Restore?

  • User profile image
    PeterF

    Hi Robert

    That's a feature I submitted as a bug more than a year ago, but is still not fixed in the installer.

    If you want to have it back to normal automatic logon, download the TweakUI utility from Microsoft.
    After installation and starting it up go to the Logon category and uncheck "Show "ASPNET" on Welcome screen" or maybe also the SQLDebugger account that is also suffering from this bug.

    So after changing this only your account and "Parse Autoxec.bat at logon" should be checked. Then press OK and on the next reboot you should notice things are back to normal.

    Good luck,
    Peter

  • User profile image
    RobertB

    Thanks, Peter. After all my searching on the web,at Microsoft and several other forums, you are only the second reply I've received.

    The first one was from a fellow in Australia.  I've got to find the printed copy of his response as it was a bit like yours.  He mentioned the ASPNET, etc. but following his instructions I did not show some of the other things me mentioned in his steps to possibly solve the problem.

    Later today or tomorrow, I will do as you suggested and try to get the problem resolved.  I'll come back here and let you know what happens.

    Thanks again for your advice and for taking the time to respond.

         Robert

  • User profile image
    PeterF

    No problem

    Install the TweakUI powertoy and you'll be able to fix it in less than a minute

    Good luck,
    Peter

  • User profile image
    RobertB

    Hi Peter.

    Downloaded and installed the Tweak UI v1.33.  Followed your instructions exactly, but when I got to the logon category the "Show ASPNET on Welcome Screen" was not checked.  The other two -- "Parse Autoexe. bat at logon" and "Show Xpuser on Welcome Screen" -- were checked.  I did not see anything about the SQLDebugger account.

    Went back and checked the Aussie's reply to see if there was anything I missed the first time around. He said he had a similar problem when the .NET Framework was first installed but it resolved itself when the SP1 was installed. He advised me to:
     "Open the Computer Management console (right click
     My Computer and choose Manage). Then disable the
     ASPNET user entry under Local User and Groups
     (Users)."
    I didn't miss anything. There just was not an ASPNET user entry anywhere to be found!

    By the way, I forgot to mention earlier that I went to KB867460 and studied many of Microsoft's multitude of fixes for .NET Framework 1.1 SP1. There's nothing there regarding this problem.

    Should you have any further thoughts re this bug, pls come back here.

    Thanks again for your interest and help.

    Robert

  • User profile image
    PeterF

    You used a very old version of TweakUI, didn't you follow the link http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx ?

    If you install that one you will be fine.
    Good luck,
    Peter

  • User profile image
    RobertB

    Hello Peter.  Thanks for setting me straight on the correct version.

    Went to the site. Downloaded and installed the 2.10.0.0 version of TweakUIPowertoySetup.exe. Regret to report that "Show ASPNET on Welcome Screen" was unchecked on this version also.  Only difference was a new check box (unchecked) for "Keep RAS connections after logoff."

    Did happen to note on one of the "Tips" that Win+L would bring up the Welcome Screen.  It did and there was the screen in all its glory, along with a listing of unread email, etc. So, I know the Welcome Screen is still in the computer!

    Before downloading the new Tweak version, I moved to the recycle bin the following:
      Powertoys for Windows XP
      Powertoys_wpchanger
      SlideshowPowertoySetup
      TweatUIPowertoySetup
    These are older versions, and I'll leave them in the bin for awhile.

    Guess I'll just have to wait for Mr. Gates and crew to come up with a fix for this irritating bug in .NET
    Framework 1.1 SP1.

    I really do appreciate your help, Peter, in trying to solve this mystery.  Should you hear of a fix later on, please come back here and post.  I'll check in from time to time.

    Regards,
           Robert

  • User profile image
    RobertB

    Hi Peter.  Hope you come back here for I, hopefully, have some good news!

    I had a thought re my problem.  What if I put a check mark in the box for "Show ASPNET on Welcome Screen">Apply>O.K. and reboot?  Did so. Then the Welcome Screen at logon came right up.  Tried it again a few minutes later -- rebooting, etc. and the Welcome Screen at logon came right back up again!

    This is opposite of what you and the Aussie suggested but it has worked for me thus far.

    Hope this does not cause any future problems, but let me know what you think. Is this change to show the ASPNET ill-advised?  Would appreciate your thoughts very much.

    Regards,
           Robert   

  • User profile image
    PeterF

    I must appologize for not reading your initial discription of your problem correctly. I was assuming you were talking about getting the welcome screen instead of automatic login after installing the .NET framework.

    What you are describing doesn't sound familiar to me. So what you want to get back is the feature to show the Welcome screen....
    If you expand Logon in the TweakUI util you'll find an Autologon category, uncheck it if it is checked... else I don't have a clue what it could be. Else leave the ASP.NET account enabled for the time being and use the Autologon featureto automatically logon if that is what you would like in the end.

    Have a nice weekend,
    Peter

  • User profile image
    RobertB

    Good Morning, Peter.

    No problem.  We were moving along in similar directions.  I haven't looked this morning, but as I recall from yesterday the Autologon was not checked.

    The Welcome Screen logon is still working fine.  It's coming back up at logon just as before except for one minor exception -- the "green hillside" Microsoft screen comes up for a split second before the Welcome Screen logon comes up.

    I plan to leave the ASPNET account enabled for the time being, as everything appears to be back to normal.

    Thanks again for staying with me on this.  And I hope you have a super weekend too!

    Robert

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.