Tech Off Thread

2 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

WCF error, Could not find default endpoint element...

Back to Forum: Tech Off
  • User profile image
    qwert231

    I've gotten this with HTTP Bindings and Named Pipes Bindings:
    "Could not find default endpoint element that references contract OrderCompletionTestClient.OrderCompletion.IOrderCompletion in the ServiceModel client configuration section."

    This error is happening in my Service Reference file: OrderCompletion.vb in this method:
    Public Sub New()
     MyBase.New
    End Sub

    Any ideas what I did wrong? I googled but didn't find much.

  • User profile image
    qwert231

    Fixed it.

    It was in the client's App.config file.

    When I originally created the Service Reference, I got this:

            <client>
                <endpoint address="net.pipe://localhost/OrderCompletion" binding="netNamedPipeBinding"
                    bindingConfiguration="NetNamedPipeBinding_IOrderCompletion"
                    contract="OrderCompletion.IOrderCompletion" name="NetNamedPipeBinding_IOrderCompletion" />
            </client>
        </system.serviceModel>
       
    But I changed it to this:   
       
           <client>
                <endpoint address="net.pipe://localhost/OrderCompletion" binding="netNamedPipeBinding"
                    bindingConfiguration="NetNamedPipeBinding_IOrderCompletion"
                    contract="TestClient.OrderCompletion.IOrderCompletion" name="NetNamedPipeBinding_IOrderCompletion" />
            </client>
        </system.serviceModel>

    TestClient being my client's name. Stupid little thing, but that did it.

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.