Tech Off Thread

4 posts

Tough one - Component Services and MSDTC issue XP Pro

Back to Forum: Tech Off
  • User profile image
    ferguslogic

    Hello everyone,

    I purchased a brand new shiny development machine last weekend (one of the  new dual core 2 processor machines...two thumbs way up!).

    The operating system on the machine is XP Pro.

    I am coding a C# 2005 winforms application which requires MSDTC and after opening my C# project and running it  I noticed that MSDTC is not installed on my new machine.  I thought MSDTC was installed on every windows machine but apparently that is not correct.

    So when I go to component services to look at the Distributed Transaction Coordinator the "my computer" icon has a red arrow over it instead of a green arrow which makes it look like there is a problem.

    If I click on the "distributed transaction coordinator" folder under component services i receive this message

    --------------------------------------------------
    cannot open this folder because connection to the msdtc service on 'My Computer' failed. Make sur that:

    The computer is running.
    You have permissions to administer the computer.
    The computer name is correct.

    --------------------------------------------------------------------------


    If I click on the "com+" folder under component services i receive this message.
    -------------------------------
    An error occurred while processing the last operation.
    Error code 8004e00F - Com+ was unable to talk to the Microsoft Distributed Transaction
    Coordinator

    The event log may contain additional troubleshooting information.
    ---------------------------------

    The event log does not contain any information and I am pretty stumped.  I double checked my  username and I am a member of the administrator group.  Any help is really appreciated.

    thanks
    Matt

     

  • User profile image
    Lee_Dale

    Have you tried stopping and starting the Distributed Transaction Coordinator in Administritive Tools -> Services?

  • User profile image
    ferguslogic

    It is not there.
    There is not msdtc service located under the services area.

    Also, if you use net start msdtc or net stop msdtc windows says it cannot find msdtc.

  • User profile image
    ferguslogic

    well i am guessing that my computer manufacturer caused this problem but here is how i fixed it.

     

    I went to a command prompt.

    I navigated to c:\windows\system32

    I ran msdtc - install

    that installed Msdtc and the service now appears under the "services" area.  Everything appears to work fine now.

    I have no idea why it was not installed.

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.