Tech Off Thread

8 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

CLR Bug

Back to Forum: Tech Off
  • User profile image
    Secret​Software

    FatalExecutionEngineError was detected
    Message: The runtime has encountered a fatal error. The address of the error was at 0x7a2d9250, on thread 0x1784. The error code is 0xc0000005. This error may be a bug in the CLR or in the unsafe or non-verifiable portions of user code. Common sources of this bug include user marshaling errors for COM-interop or PInvoke, which may corrupt the stack.

    why would this error happen? I keep getting this at random areas of my code when debugging.


  • User profile image
    pdhooper

    Are you using mixed-code, i.e. non-managed code?
    I've had this issue and its normally to do with a memory problem in the unmanaged code, like double deletion etc

  • User profile image
    Secret​Software

    pdhooper wrote:
    Are you using mixed-code, i.e. non-managed code?
    I've had this issue and its normally to do with a memory problem in the unmanaged code, like double deletion etc


    The code at which this error happens, is completely managed. It does not happen in any p/Invoke code blocks.Perplexed

  • User profile image
    JChung2006

    You left a ton of information out of your "CLR Bug" report.  Which version of the CLR are you using?

  • User profile image
    Secret​Software

    JChung2006 wrote:
    You left a ton of information out of your "CLR Bug" report.  Which version of the CLR are you using?


    I am using the latest VS2005 SP1 bits.

  • User profile image
    JChung2006

    What classes and methods were you using when the error occurred?
    What operating system(s) were you running?

  • User profile image
    Secret​Software

    JChung2006 wrote:
    What classes and methods were you using when the error occurred?
    What operating system(s) were you running?


    OS: Windows Vista Ultimate + Latest Updates

    Classes :CryptoServiceProvider{SignData,VerifyData},XmlDocument{Load}. Also the error happened when bitshifting {some int value >> 3).

    not sure what causes this but it seems to be all over the place.

  • User profile image
    JChung2006

    Which CryptoServiceProvider?

    Check out the .NET security blog (http://blogs.msdn.com/shawnfa/).  Maybe he can help you out.

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.