Tech Off Thread

3 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

Can't Debug with EVC4 on CE5

Back to Forum: Tech Off
  • User profile image
    Void

    Guys,

    I'm hoping one of you CE gods can help with a problem I'm haveing.  Actualy I'm in a CE5 platform builder training class with about 10 ohter developers.  We all have the same problem so it's not an individual issue.

    We have a project buitl completly by the wizard as "Typical Hello World" and no extra code at all.  We can run the app from inside EVC4 via Active Synce without a problem.

    When we set a break point and try running in debug mode, before the code download seems to start we get an error.

    /'Platform Manager faild to queue CEMON pkg."  Followed by what looks like a long GUID.

    Any ideas? 

  • User profile image
    Mike Dimmick

    Have you got:

    1. eVC 4.0 SP4
    2. An SDK exported from Platform Builder for your platform?
    3. The correct SDK selected in eVC?

    If you don't have those, I don't think it'll work. The second is required so that Platform Manager downloads the correct versions of the device debugging components (the Platform Manager transport layer components and CEMON.EXE, the remote end of the eVC debugger).

  • User profile image
    Void

    Yes on eVC 4.0 SP4

    Yes on the SDK.  We did not have a SDK expored from our platform project initaly but we did try that soon.

    We tried the basic SDK and the one exported from Platform Builder.  Same error, as described on both.

    We are working with a Sharp based design and there is a known issue with the compiler related to the SDK.  I don't remember the details but we have a 4i and we have to use the 4 (non-i) version of the SDK which does cause warnings when we try to run the app.  But the debugger was suposed to work. And, we did create a SDK to test for this issue.

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.