Tech Off Thread

6 posts

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

shutdown.exe - Foiled by a screensaver?

Back to Forum: Tech Off
  • User profile image
    W3bbo

    When I attempt to shut down idle computers on my home's LAN I often find the command doesn't work, invariably because a screensaver was currently executing.

    Take any XP box idling at the logon screen with logon.scr running and execute shutdown -s -t 0 -m \\machineName against it.

    You'll find the machine doesn't do anything until you deactivate the screensaver, only then does it shutdown.

    Is there any way to make the shutdown command ignore the screensaver?

  • User profile image
    SlackmasterK

    W3bbo wrote:
    When I attempt to shut down idle computers on my home's LAN I often find the command doesn't work, invariably because a screensaver was currently executing.

    Take any XP box idling at the logon screen with logon.scr running and execute shutdown -s -t 0 -m \\machineName against it.

    You'll find the machine doesn't do anything until you deactivate the screensaver, only then does it shutdown.

    Is there any way to make the shutdown command ignore the screensaver?


    You could precede the shutdown command with a taskkill.

  • User profile image
    evildictait​or

    Have you tried using a different screensaver? Maybe it's just a nasty one that's not responding to WndProc properly.

    Also, depending on what your current scenario is, you could always just turn the screensaver plain off.

  • User profile image
    Jorgie

    Did you try the /f force option?

    Nevermind... the docs say that /f is assumed then you provide a timeout.

    I have not run into the problum you are having. Then again all my systems are set to to use the 'blank' screen saver as I just want the monitors to go into engery saver mode as soon as it kicks in.

    Jorgie

  • User profile image
    littleguru

    Interesting that it doesn't work for you. I used often the blank screensaver and the shutdown with a timeout (like a hour or so) to shut the computer down while I was asleep... it did always work properly for me.

  • User profile image
    SlackmasterK

    Jorgie wrote:


    I have not run into the problum you are having. Then again all my systems are set to to use the 'blank' screen saver as I just want the monitors to go into engery saver mode as soon as it kicks in.


    Then why not just set it to "None"?

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.