Tech Off Thread

11 posts

VS 2008 - writing code is hella slow?

Back to Forum: Tech Off
  • User profile image
    modi123

    I just installed VS 2008 at work, opened up a project I was just working on in 2005 and I noticed a significant slowdown in my ability to crank out code.  would it be the intellisense that is doing this?  Is there a way to turn off the intellisense's filter? 

    Specifically I was typing out a variable declaration in a function.  

             dim variable_name as decimal = me.header(0).column name

    I am getting about a 7 to 10 second lag for that text to show up, but a bunch of flickering from the intellisense windows briefly showing up and disappearing.


    Anyone else getting this problem?  Any fixes to make writing code as fast as 2005?

    Thanks in advance…

    (Oh lookie, my function I wrote up before posting this just appeared in my code.. yeppie!)

  • User profile image
    stevo_

    Well thats obviously not what is standard experience, but also, although there aren't any real guidelines for fields, you should avoid the underscore (it may even be part of the guidelines to avoid underscores at any location), you should also ensure you are using the tighter compilation rules when using VB.. so that VB doesn't do automatic casting..

  • User profile image
    evildictait​or

    Post your machine specs.

  • User profile image
    modi123

    evildictaitor wrote:
    Post your machine specs.


    I doubt it is a machine speed issue.  I was in 2005 yesterday - it worked speedily enough.  I installed 2008 today and intellisense is slowing everything down to a crawl.... Regardless: intel dual core d 3.20ghz, 2 gigs of ram, 2-256mb radeon cards...

    stevo_ wrote:
    Well thats obviously not what is standard experience, but also, although there aren't any real guidelines for fields, you should avoid the underscore (it may even be part of the guidelines to avoid underscores at any location), you should also ensure you are using the tighter compilation rules when using VB.. so that VB doesn't do automatic casting..


    Stevo_ ... that was just an example of what I was talking about not the actual line of code. 



    Does anyone know how to turn off the intellisense filtering, and bring intellisense back to 2005 "show all" style for VB?  I have been in and out of the options without luck.  (though I am amused by the check box "pretty listings"). 

  • User profile image
    RichardRudek

    I probably shouldn't say anything, I've only used the Beta versions of VS2008. But I would expect that the usual speed up tips apply: Turn off Dynamic Help, defragmenting, removing background tasks, disabling or reducing the functionality of AntiVirus/Malware monitors, restarting...

    If that doesn't help, then run [Process Monitor], and see if you can narrow it down

  • User profile image
    modi123

    RichardRudek wrote:
    I probably shouldn't say anything, I've only used the Beta versions of VS2008. But I would expect that the usual speed up tips apply: Turn off Dynamic Help, defragmenting, removing background tasks, disabling or reducing the functionality of AntiVirus/Malware monitors, restarting...

    If that doesn't help, then run [Process Monitor], and see if you can narrow it down


    Unless VS2008 is some sort of resource hog ala visa styling I doubt this will help.  I am fairly certain it's intellisense issue.. my machine is NOT slowing down, just me interacting with VS2008 in terms of typing code out.  The interaction with VS2008 versus my interaction with VS2005 is slower, and it has to do with intellisense trying to guess what I am doing with every key stroke.

    I really just want the intellisense to act like 2005.. is that even possible?

  • User profile image
    LisaF

    modi123 wrote:
    

    I just installed VS 2008 at work, opened up a project I was just working on in 2005 and I noticed a significant slowdown in my ability to crank out code.  would it be the intellisense that is doing this?  Is there a way to turn off the intellisense's filter? 

    Specifically I was typing out a variable declaration in a function.  

             dim variable_name as decimal = me.header(0).column name

    I am getting about a 7 to 10 second lag for that text to show up, but a bunch of flickering from the intellisense windows briefly showing up and disappearing.


    Anyone else getting this problem?  Any fixes to make writing code as fast as 2005?

    Thanks in advance…

    (Oh lookie, my function I wrote up before posting this just appeared in my code.. yeppie!)



    Hi modi123,

    I believe you are running into the following issue:
    http://support.microsoft.com/kb/946452
    A fix will be included in SP1 and will be linked from the KB article once available.

    In the meantime, there is a workaround. Please turn off the option to "Generate XML documentation file". Here are instructions to find that option:
    - Double-click "My Project" in Solution Explorer.
    - Navigate to the "Compile" tab of the App Designer that appears.
    - Go to the bottom of the page and un-check the option.

    Please let me know if that solves your issue.

    Thanks,
    Lisa Feigenbaum
    VB IDE Program Manager
    vbuitri@microsoft.com

  • User profile image
    modi123

    LisaF wrote:
    
    modi123 wrote:
    

    I just installed VS 2008 at work, opened up a project I was just working on in 2005 and I noticed a significant slowdown in my ability to crank out code.  would it be the intellisense that is doing this?  Is there a way to turn off the intellisense's filter? 

    Specifically I was typing out a variable declaration in a function.  

             dim variable_name as decimal = me.header(0).column name

    I am getting about a 7 to 10 second lag for that text to show up, but a bunch of flickering from the intellisense windows briefly showing up and disappearing.


    Anyone else getting this problem?  Any fixes to make writing code as fast as 2005?

    Thanks in advance…

    (Oh lookie, my function I wrote up before posting this just appeared in my code.. yeppie!)



    Hi modi123,

    I believe you are running into the following issue:
    http://support.microsoft.com/kb/946452
    A fix will be included in SP1 and will be linked from the KB article once available.

    In the meantime, there is a workaround. Please turn off the option to "Generate XML documentation file". Here are instructions to find that option:
    - Double-click "My Project" in Solution Explorer.
    - Navigate to the "Compile" tab of the App Designer that appears.
    - Go to the bottom of the page and un-check the option.

    Please let me know if that solves your issue.

    Thanks,
    Lisa Feigenbaum
    VB IDE Program Manager
    vbuitri@microsoft.com



    Holy sh*t!  Lisa, I love you!  This clears up the problem 100%!  I knew I wasn't crazy! 

    Problem solved (until SP1 squashes it)!   Thank you again!

  • User profile image
    RichardRudek

    OK, but my point is that you should not ignore things in ignorance.

    In other words, it probably is intellisense. But as your having trouble "reconfiguring" it, you may as well check these other things until the appropriate advise comes along. It shouldn't hurt, and it gives you real confidence that it's not a hardware induced problem.

    For example, your assuming that your hard disk is not failing - that the new installation of VS2008 (or even the pagefile, perhaps having increased) has not been placed in a faulty (failing) part of the hard disk, and thus having to retry it's accesses - I'm sure your familar with the slow downs (freezes) you get when trying to access a CD/DVD drive. Same idea.

    That's what I'm trying to have you check. It's a new installation, and perhaps something silly is happening...


    At any rate, do what you like. I assume you've tried searching. I seem to recall there were registry and/or command-lines that you could use to disable things, and even 'reset' your VS configuration.


    Anyway, other things to do...


    EDIT: Good you found the advise... Smiley

  • User profile image
    apps88

    Hi Lisa,

    That solved a similar problem which I was experiencing.

    Unfortunately, the KB Article link which you quote is unavailable. Do you have an up to date link for the article?

    Regards,

    Patrick Holmes

  • User profile image
    figuerres

    LisaF wrote:
    
    modi123 wrote:
    

    I just installed VS 2008 at work, opened up a project I was just working on in 2005 and I noticed a significant slowdown in my ability to crank out code.  would it be the intellisense that is doing this?  Is there a way to turn off the intellisense's filter? 

    Specifically I was typing out a variable declaration in a function.  

             dim variable_name as decimal = me.header(0).column name

    I am getting about a 7 to 10 second lag for that text to show up, but a bunch of flickering from the intellisense windows briefly showing up and disappearing.


    Anyone else getting this problem?  Any fixes to make writing code as fast as 2005?

    Thanks in advance…

    (Oh lookie, my function I wrote up before posting this just appeared in my code.. yeppie!)



    Hi modi123,

    I believe you are running into the following issue:
    http://support.microsoft.com/kb/946452
    A fix will be included in SP1 and will be linked from the KB article once available.

    In the meantime, there is a workaround. Please turn off the option to "Generate XML documentation file". Here are instructions to find that option:
    - Double-click "My Project" in Solution Explorer.
    - Navigate to the "Compile" tab of the App Designer that appears.
    - Go to the bottom of the page and un-check the option.

    Please let me know if that solves your issue.

    Thanks,
    Lisa Feigenbaum
    VB IDE Program Manager
    vbuitri@microsoft.com



    Lisa,

    thank you very much for the reply to the post! 
    I wish more of the MSFT folks would drop in like that Smiley

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.