Tech Off Post

Single Post Permalink

View Thread: Why does tlbimp.exe work but direct reference from VS2008 not work on some COM components?
  • User profile image

    pompomJuice said:
    pdev said:
    That was genius.

    It worked!!!!

    I was googling all day and found nothing. Thanks a lot I would never have figure this out, partly to the fact that it seems like a random fix. 

    I googled that exe but I dont find much info on it. Where can I find more info on why there was an error and why this worked?

    Thanks again.

    Ah cool, I'm glad that worked for you.  So the tools use to come with .Net 2.0, but it appears they're not shipped with .Net 3.5.  I'm not sure why they're no longer shipped, but you got it to work without them so no worries.  It probably looking in the relative directory and found the tbl itself, so there was no need to register it.

    So why did this work?  Type Libraries are binary files that define how you communicate with a COM object.  Typically the type library is embedded into the object itself, but sometimes it's not.  In your case I assume found the tbl on your computer so there were no issues, but on the remote machines it was missing and Visual Studio simply didn't have the information it needed to use the object.