Tech Off Thread

9 posts

Horizontal window error

Back to Forum: Tech Off
  • User profile image
    lesmemphis

    I've got the wierdest bug :

     

    When I run my website from my local host, everything works fine, but when I run the website live from a web server, IE renders my dropdown menu as blank. It still works fine on Firefox etc, but not in IE when live. As I mentioned, IE is fine when on local server.

     

    What could be the cause of this, and how can I solve it?

  • User profile image
    spivonious

    Maybe the dropdown isn't getting filled with items, e.g. bad link?

  • User profile image
    figuerres

    Hmmm

     

    how are the menus built and displayed?

    i wonder if you have possibly an optional style sheet for IE that is not geting downloaded on the live site?

    or some javascript that is for IE as a menu helper?

     

    thats what i would check first as you say firefox is ok and many menu designs use alternate css to handle IE6 issues.

     

  • User profile image
    lesmemphis

    figuerres said:

    Hmmm

     

    how are the menus built and displayed?

    i wonder if you have possibly an optional style sheet for IE that is not geting downloaded on the live site?

    or some javascript that is for IE as a menu helper?

     

    thats what i would check first as you say firefox is ok and many menu designs use alternate css to handle IE6 issues.

     

    Hey,

     

    thanks, I'll check into it and let you know if I resolved the issue.

  • User profile image
    lesmemphis

    lesmemphis said:
    figuerres said:
    *snip*

    Hey,

     

    thanks, I'll check into it and let you know if I resolved the issue.

    Wierd thing is that it works fine on all browsers in the home page. It's when i go to the subpages that it gets renered as blank white.

     

    I thought it could be a sintax issue when you render the url to the subpages (which is in their own folder), but I've tried different ways to call it and still get the same bug.

  • User profile image
    figuerres

    lesmemphis said:
    lesmemphis said:
    *snip*

    Wierd thing is that it works fine on all browsers in the home page. It's when i go to the subpages that it gets renered as blank white.

     

    I thought it could be a sintax issue when you render the url to the subpages (which is in their own folder), but I've tried different ways to call it and still get the same bug.

    same thing ....

     

    are the other pages in folders under the main page ?

    /default.aspx

    /one/default.aspx

    /two/default.aspx

     

    if yes then look at the links to the css and js files and make sure they are valid.

     

    for example does the css and js  use ./file.css or does it use /file.css  to link the css or js files?

     

    ./file would work in the root folder but on in a sub-folder  as "." means current folder

     

    stuff like that.

  • User profile image
    lesmemphis

    figuerres said:
    lesmemphis said:
    *snip*

    same thing ....

     

    are the other pages in folders under the main page ?

    /default.aspx

    /one/default.aspx

    /two/default.aspx

     

    if yes then look at the links to the css and js files and make sure they are valid.

     

    for example does the css and js  use ./file.css or does it use /file.css  to link the css or js files?

     

    ./file would work in the root folder but on in a sub-folder  as "." means current folder

     

    stuff like that.

    cool, thanks, will do!

  • User profile image
    lesmemphis

    Issue is officially resovled!!! Cool

     

    found my answer here:

     

    Popout menus not displayed in IE 8.0

  • User profile image
    figuerres

    lesmemphis said:

    Issue is officially resovled!!! Cool

     

    found my answer here:

     

    Popout menus not displayed in IE 8.0

    cool and interesting!

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.