Tech Off Thread

5 posts

Setting default IE in WPF app?

Back to Forum: Tech Off
  • User profile image
    VengenceBot

    im currently making a WPF app with webbrowser on a x64 machine.. The only problem im having is that the WPF is making IE 64bit run as defualt.. Im also using the Express version which I think only makes 32bit apps..?

    Is there something Im doing wrong or what can I do.. !

  • User profile image
    spivonious

    64-bit apps in .NET can only interoperate with other 64-bit apps. This is why the webbrowser component is using the 64-bit IE engine. I'm not familiar with the Express versions of VS, but look for an option in the compiler settings that says something like "AnyCPU" and change it to "x86". That should fix your problem.

     

    Otherwise, your app will only use 32-bit IE when run on 32-bit Windows.

  • User profile image
    VengenceBot

    spivonious said:

    64-bit apps in .NET can only interoperate with other 64-bit apps. This is why the webbrowser component is using the 64-bit IE engine. I'm not familiar with the Express versions of VS, but look for an option in the compiler settings that says something like "AnyCPU" and change it to "x86". That should fix your problem.

     

    Otherwise, your app will only use 32-bit IE when run on 32-bit Windows.

    I know what you are talking about, but for some reason its not given me the option in this project.. ill try another soon or start over ect..!

  • User profile image
    W3bbo

    VengenceBot said:
    spivonious said:
    *snip*

    I know what you are talking about, but for some reason its not given me the option in this project.. ill try another soon or start over ect..!

    The option to set an assembly as being processor-specific is buried in the VS UI, it isn't immediately obvious.

     

    You can either change it via a hidden menu on the Solution Configuration window, or open Project Properties > Build > Platform Target > "Any CPU" | x64 | x86.

     

    ...though I don't see how running an instance of the WebBrowser control would cause the Default Programs option for IE to change. Something doesn't sound right.

  • User profile image
    VengenceBot

    W3bbo said:
    VengenceBot said:
    *snip*

    The option to set an assembly as being processor-specific is buried in the VS UI, it isn't immediately obvious.

     

    You can either change it via a hidden menu on the Solution Configuration window, or open Project Properties > Build > Platform Target > "Any CPU" | x64 | x86.

     

    ...though I don't see how running an instance of the WebBrowser control would cause the Default Programs option for IE to change. Something doesn't sound right.

    sorry its been a while work weekends night lol..

     

    Well an update to the problem.. I did my own project as I was reverse engineering a sample... and I do have it working now!

    Not sure what the problem was or the person did.. So this problem is considered closed.. 

     

    YEAH im happy 

     

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.