Tech Off Thread

1 post

Forum Read Only

This forum has been made read only by the site admins. No new threads or comments can be added.

WebDev 2010 - Crashy Server

Back to Forum: Tech Off
  • User profile image
    ManipUni

    The temp server that ships with WebDev 2010 is very quick to crash. Unclear why at this stage. Has anyone seen this before while developing on it?

    System.NullReferenceException was unhandled
      Message=Object reference not set to an instance of an object.
      Source=WebDev.WebHost40
      StackTrace:
           at Microsoft.VisualStudio.WebHost.Request.IsBadPath()
           at Microsoft.VisualStudio.WebHost.Request.TryParseRequest()
           at Microsoft.VisualStudio.WebHost.Request.Process()
           at Microsoft.VisualStudio.WebHost.Host.ProcessRequest(Connection conn)
           at Microsoft.VisualStudio.WebHost.Host.ProcessRequest(Connection conn)
           at Microsoft.VisualStudio.WebHost.Server.OnSocketAccept(Object acceptedSocket)
           at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
           at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
           at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
           at System.Threading.ThreadPoolWorkQueue.Dispatch()
           at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()
      InnerException:

     

    Here is the request I am making:

    GET / HTTP/1.1
    User-agent: Placeholder
    Host: localhost:54717

     

    If I remove HTTP/1.1 I get a "File Not Found" (even requesting /) and if I keep it in the server throws an exception. This exception is outside the scope of my project, it is a server exception.

Conversation locked

This conversation has been locked by the site admins. No new comments can be made.