Check your web.config setting.

  <system.webServer>
    <handlers>
        <add name="cgi-bin" 
         path="*.py" 
         verb="*" 
         modules="CgiModule" 
         scriptProcessor="C:\Python\python.exe %s %s" 
         resourceType="Unspecified" />
    </handlers>
  </system.webServer>

Have you enabled verb "GET" (or just use wildcard "*") for extension ".py"? (Make sure you've modified the scriptProcessor attribute above to match your python path.)