Tech Off Thread

4 posts

ODBC Data provider & 64bit oracle client: arithmetic operation resulted in an overflow

Back to Forum: Tech Off
  • User profile image
    Jimi2Cool

    I am currently trying to migrate an application off of the Oracle data provider and onto the Odbc provider. 

     

    Everytrhing seems like it should be working and the transiotion was (until now) very straightforward as i'm using no  oracle specific features and only executting very simplwe select statements with a couple joins. I have done this sort of thing before without issue but that was back in .Net 3x on x86 architectures. Now i'm trying this with Oracle 11g 64bit client, .net 4.0 on a 64bit system.

     

    Everything compiles, connections open, commands created then on ExecuteReader (or DataAdapter.fill() as i've tried both) I get the following error:

     

    "arithmetic operation resulted in an overflow"

     

    I've looked EVERYWHERE and have tried EVERYTHING i can think of. I've even tried running this all inside an unchecked{} block to no avail. This seems to be a topic on plenty of forums:

     

    http://social.msdn.microsoft.com/Forums/en-CA/clr/thread/ac3776fc-5231-4c7e-a0dc-825043871cc8

    https://forums.oracle.com/forums/thread.jspa?threadID=327112

     

    But there are no real answers anywhere.

    ANY help, hack or workaround would be awesome!

     

  • User profile image
    figuerres

    what are the datatypes in this ???

    i would think that you might have somewhere a mis-match like say in .net if you had a an INT but if oracle was sending back a UINT or a LONG then you will have an overflow on conversion or something like that.

  • User profile image
    spivonious

    What are you pulling back? It sounds like one of the values is bigger than System.Decimal can hold.

  • User profile image
    manojmathe

    @Jimi2Cool: are you able to solve this problem ?

    i am into the same issue can you please help me

Comments closed

Comments have been closed since this content was published more than 30 days ago, but if you'd like to continue the conversation, please create a new thread in our Forums, or Contact Us and let us know.