Loading user information from Channel 9

Something went wrong getting user information from Channel 9

Latest Achievement:

Loading user information from MSDN

Something went wrong getting user information from MSDN

Visual Studio Achievements

Latest Achievement:

Loading Visual Studio Achievements

Something went wrong getting the Visual Studio Achievements


RichardRudek RichardRudek So what do you expect for nothin'... :P
  • Vista and Flash Media Server

    Have you checked whether it's an Ethernet MTU (MaximumTransfer Unit) issue. ?

    I believe Vista has a dynamic tuning algorithm. In which case, it's possible that Vista is detecting a black hole Router, and it's reaction to that could be manifesting itself with this Server - ie the Media Server is making invalid/inappropriate assumptions about the lower-level network transport, and eventually fails.

    Just a guess. If you really want to get into it, try using WireShark or Microsoft's Network Monitor to capture the network packets as it starts to fail.

  • USB cannot read barcode scanner

    jellylychee wrote:
    RichardRudek wrote:
    You'll also need to explain what you mean by doesn't work. eg  it seems to be getting no power, etc

    I've re-quoted my earlier question.

    jellylychee wrote:
    Hi. I am sorry I got everyone mixed up.  It has a ps/2 connector. It is working fine when I connect it to the ps/2 port of my desktop. It can read the barcodes and send the data to the desktop. However when I use a ps/2 usb adapter converter (my laptop doesnt have a ps/2 port), my computer does not recognize the barcode scanner anymore. The adapter converter is working fine when I tried to connect other devices like a mouse.

    Anymore ?

    Does that mean the barcode scanner used to work on the laptop, but then stopped for some reason ?

    If so, then [read through this post] (or even the thread), and see whether it sue to bad Device manager entries. Specifically what we're looking for will be any HIDs (Human Interface Devices).

    Also, have you tried plugging in the desktop's keyboard along with the barcode scanner, like you would (I assume) with your dekstop ?

  • USB cannot read barcode scanner

    figuerres wrote:
    figuerres wrote:
    jellylychee wrote:

    The scanner has a

    6pin male and female connector.

    It did not come with a driver. I just borrowed it from my school for my thesis. They do not have a USB scanner sad to say.


    starting to think this is a PS/2 keyboard wedge eh?

    perhaps the OP has a PS/2 = USB adapter ??

    Yes, I'd surprised if it was primarily an RS232 device: [Barcode scanners]

    Most of the ones I've seen are the keyboard-injection type devices, because that's the simplest way of doing it - no drivers necessary.

    Now the wikipedia article does mention that a few of these devices do have RS232 interfaces. But the device still needs to get it power from somewhere.

    The PS/2 interface has a 5 Volt supply, so that's the most probable source. But older, RS232-only devices typically scavenged their power from the RS232 interface itself.

    But, those devices may not be able to derive enough power from a 'non-strict' RS232 interface - RS232 is suppose to be +/- 12 Volt signaling. But a lot of 'adapters' have 'customised' this standard, using much lower voltages, or not even using negative voltages.

  • USB cannot read barcode scanner

    As figuerres has said, these devices usually 'inject' their data stream as though someone had typed it in via a keyboard. So for all intents and purposes, it is a keyboard.

    But just to be sure, here are some links so you can confirm exactly what you have: [PS/2 connector]   [DE-9 connectors]

    Also, whilst the keyboard data stream is a serialised one, it's not RS-232, which is what your suggesting when you talk about serial ports - which is probably why figuerres introduced the possibity of it being an RS-232 device - I'd doubt it.

    You'll also need to explain what you mean by doesn't work. eg  it seems to be getting no power, etc.

  • VS 2008 Start Options Bug

    You might need to use a batch file then.

    PS: I don't have VS2008, so I can't experiment...

  • Cloning volumes and now they're unbootable?

    W3bbo wrote:
    RichardRudek wrote:
     and that the 40GB still works on the laptop.
    I just went:

    Take source drive out of laptop > Hook it and the destination to the controller card > Boot up > Ghost > Advanced > Clone > Source disk / Destination disk > Continue > Reboot > Unattended clone operation > Shut down > Disconnect drives > Put back into laptop > Fail

    Note I've highlighted part of my previous question which you forgot to answer.

    I can't see anything obviously wrong, though I don't use the clone feature, so don't actually know what it does.

    When I do a replacement, I first backup to an image file on my server (over the LAN), replace the disk, then disk image back from the image file on my server. I have a specially hacked up boot CD for this.

    That way I have a backup of their hard disk before I touched the hardware in any major kind of way, and I can choose to grow the original disk partition on the new, larger disk. It's slower, but safer (IMHO), and I have a backup.

    Now if cloning does grow the partition as well, then I wonder whether it's gone and done something stupid like moving the bootstrap files (or part-thereof) beyond the 8GB zone (~7.8 GB actually).

    Actually, can you confirm what partition entry the original partition (40GB) was using, and what the new one (120GB) uses - there are four of them within the MBR/Partition table, starting at offset 0x01BE (446).

    That is:
        Partition 1 - offset 0x01BE (446)
        Partition 2 - offset 0x01CE (462)
        Partition 3 - offset 0x01DE (478)
        Partition 4 - offset 0x01EE (494)

  • Cloning volumes and now they're unbootable?

    There could be a number things at play here. But it is strange your not getting any errors.

    Maybe you need to explain how you hooked up the two hard disk and performed the disk images, and whether you have had the two disks connected at the same whilist windows was up and running. That is, there is an entry within the registry about what volume a specific disk (signature) should be mounted as.

    Also, please confirm that we're talking about VIsta, which version it is, and that the 40GB still works on the laptop.

    I'm thinking that you might be doing something naughty like running an OEM specific version on the wrong brand of laptop... [A]

  • VS 2008 Start Options Bug

    have you tried escaping the '>' (stream redirection) character ?

    eg  ^>   or   %> 

  • Create Shared Folder Using Batch File or VBS

    Greg M wrote:
    It's sometimes hard to believe that such a long correspondence can be resolved with just four little lines of code:

    Md G:\MyFolder
    Net Share MyShare=G:\MyFolder
    Cacls G:\MyFolder /e /r Everyone
    Cacls G:\MyFolder /e /g Everyone:C

    Your unlikely to need the revoke step.

    I only did it in my example because initially, I was using an existing Share that was created using the Sharing Wizard. But I left it in because I wanted to show that how it can be done, as, let's face it, CACLS is not exactly user friendly, nor unambiguously documented.

    Hell, I often forget to add the /e to the command-line, and just blow away the entire ACL, for all but the specific account supplied.

    Also, at first glance, it's not obvious what the difference is between the /g and /p switches:
    • grant (/g) is suppose to add permissions to any existing ones.
    • replace permission (/p) is suppose to entirely replace any existing permissions with what your suppling on the command-line now.
    But without the /e , apart from blowing away all the permissions from the other accounts, whats the difference between them ? ... my head hurts...

    Anyway, what I've learnt is that if CACLS ever asks 'Are you sure', say no ! ... Wink

    Oh, and to further clarify, the ACLs are 'stored' in the filesystem, not in the Registry. Kind of like the way a file's size and it's access/modification times are stored.

    That's why if you move a Hard Disk between two systems, an Administrator needs to take ownership of files first, before correcting their ACLs - the new system will likely not have the same user accounts setup (user IDs, etc). All good fun...

  • How to call C#.NET dll from javascript

    I can think of only two, perhaps three ways.

    1. This will work only with Internet Explorer. Rewrite the Class library to expose itself via COM. Specifically, as an ActiveX. Then, the ActiveX can be setup/registered on EACH client, and you can then use IE's proprietary ActiveXObject - assuming you've marked it safe for scripting.

    2. Rewrite the Class Library so that it is now a plugin to the browser. That's for each browser you want to support. So at a minimum, for IE and Firefox. I doubt you could use .NET for that, so you'll probably need to really rewrite using a different language.

    3. Find or write a generic plugin that allows the browser to consume a .NET library. A lot of work, and you'd probably need to also design (and support, version, etc) an interface between the plugin and the .NET Class Library.

    Now with each of these options, none are trivial to do. The first is probably the easiest, but apart from being limited to IE, you also need to cope with the fact that some client PC's may not have the .NET runtime installed. Strange, but true...

    I suspect you need to back to the drawing board with this one. Such as redoing it using Silverlight 2.0 (which is still in Beta), or whatever the Macromedia one is (Flex ?).