Loading user information from Channel 9

Something went wrong getting user information from Channel 9

Latest Achievement:

Loading user information from MSDN

Something went wrong getting user information from MSDN

Visual Studio Achievements

Latest Achievement:

Loading Visual Studio Achievements

Something went wrong getting the Visual Studio Achievements


TimP TimP

    CompGuy101 wrote:
    What can F# do that I cannot do in VB / C#?

    Nothing, it's the ease and clarity of implementation that's different.

  • Why doesn't Microsoft buy SCO?

    The problem is that Microsoft does not emulate the S3 Trio properly. The hardware S3 Trio supports 24-bit color, VPC tells Linux it has an S3 Trio, so Linux assumes it has 24-bit support, and you're blaming this problem on Linux? If you don't or can't emulate a video card properly, just make your own. VMware uses their own SVGA adapter that doesn't exist in any hardware form, yet Linux supports it out of the box.

  • Why doesn't Microsoft buy SCO?

    DigitalDud wrote:
    OSX is the only *nix OS that is truly user friendly, by a long shot.

    A/UX is pretty user friendly on my Quadra 650. All the coziness of System 7 with SVR3 UNIX underneath. Smiley

  • Why doesn't Microsoft buy SCO?

    To follow up, try typing uname -a on your department Unix machine to identify the kernel. While it may look like Unix, I would be genuinely surprised if it was SCO Unix, since I've never heard of any universities running it this decade.

  • Why doesn't Microsoft buy SCO?

    Shining Arcanine wrote:
    Perhaps I am going a bit far, but I would really like the ability to buy a copy of Unix for my home PC for $15.75 at my university's store like I can with Windows Vista Ultimate, so I tried to make the best case I could for why Microsoft should buy SCO.


    Besides, I think that Novell vs. SCO lawsuit determined that SCO never "owned" Unix and that all Unix-related assets belong to Novell.

  • Multithread​ing in C on Unix

    Assembler programming is nice, but there's a reason operating systems and programs aren't written in it anymore, and it's not because the software developers aren't "hardcore" enough.

  • Multithread​ing in C on Unix

    I got my code working and noticed it was only running at about 108% CPU out of a potential "400%" on a quad processor machine. It seems that the overhead in thread creation and joining outweighs the benefit. Just to make sure, I added a CPU intensive loop to each function call and achieved 400% utilization on the machine. It seems like dispatching larger amounts of work would be more efficient.

    For example:

    void prime(int low, int high)
        /* do the calculation high-low times */

    Thread 1: prime(0, 511)
    Thread 2: prime(512, 1023)
    Thread 3: prime(1024, 1535)
    Thread 4: prime(1536, 2047)

  • Multithread​ing in C on Unix

    I have a basic (on paper) understanding of pthreads, but it seems like you could do something like this.

    int numThreads = 4;
    int bigPrime = 2048; /* largest value of 2^bigPrime you're looking for */

    for(int i = 0; i < bigPrime; i += numThreads)
       for(int j = 0; j < numThreads; j++)
          pthread_create(yourFunction, (i + j));

    I made up the pthread function arguments, but those functions do exist and would seem to be the ones you need. For each pass of the outer loop, it creates numThreads threads and waits for them to finish, then bumps up the next base number to look for another numThreads number of primes.

  • Windows Vista Not Seeing My 4GB Ram

    PAE cannot be used on Vista.

  • Concering "system ​integrity&q​uot; error (0xC004D401)


    Logged in over remote desktop, I just saw this error. Obviously it's slightly concerning to see that an "unauthorized change was made to Windows" since this error message showed up while the computer was in a screensaver.

    Some event log digging yielded this:

    Code integrity determined that the image hash of a file is not valid. The file could be corrupt due to unauthorized modification or the invalid hash could indicate a potential disk device error.

    File Name: \Device\HarddiskVolume1\Windows\System32\l3codeca.acm

    Running Vista Ultimate x64. Can someone MD5 that file and tell me what they get?

    My results:

    c:\Windows\System32>md5sum l3codeca.acm
    3bb9e6aec59f77f5ea935591bef18c5e *l3codeca.acm

    c:\Windows\System32>sha1sum l3codeca.acm
    59c873741391cb4abf7783b3de119f11a42192c0 *l3codeca.acm

    I haven't installed anything in weeks either. Slightly annoyed and concerned. Sad I initially couldn't access the control panel either. I rebooted and didn't see any follow-up errors and the control panel worked again.

    I would be very appreciative if someone could shed some light on what's happening. I see that some programs apparently trigger this, but I don't have any of the listed culprits.