Defrag Tools #152 - Media eXperience Analyzer part 4: Video Glitch Analysis

Sign in to queue

Description

In this episode of Defrag Tools, Chad Beeder and Jorge Novillo continue a series on Media eXperience Analyzer (MXA). We examine a video glitch scenario, and show how to use MXA to determine what caused the problem.

Media eXperience Analyzer (formerly WindowsXRay) is a tool used to visualize ETW traces, with a particular emphasis on media scenarios such as audio/video capture and playback.

Timeline:
[00:00] Introductions and overview
[01:10] For an introduction to MXA, and explanation of how to capture a trace, refer to Defrag Tools Episode #149.
[01:20] Loading the trace into MXA
[02:28] Step 1: Look at the Video Glitches and Video Glitches Severity datasets to see where the glitches happened and how bad they were.
[05:00] Step 2: Zoom in on a glitch and look at the DX VSync ISR/DPC Cadence dataset
[05:52] Handy MXA tip: Press the ` key (grave accent) to automatically rescale the Y-axis of the graph.
[08:34] Trace shows the graphics driver skipped a VSync - next step is to follow up with the graphics driver vendor
[10:25] Email us at defragtools@microsoft.com

Embed

Download

The Discussion

  • User profile image
    ScottHuang

    Hi Chad,

    I try to analyze a issue with MXA.

     if user try to speed forward or speed backward when they watching a movie, the movie will freeze for a about 10 seconds.  Can this issue be called "glitch"? if yes, how to measure this issue. I try use "video glitch severity", but it seems don't match the user experience I got.

    thanks.

     

  • User profile image
    ChadBeeder

    @NG7711: No, I don't think that would show up in the trace as a glitch. Is this when streaming a movie over the network, or playing back from local media?

  • User profile image
    ScottHuang

    @ChadBeeder: It's a local video.

  • User profile image
    MrXRay

    @NG7711 when you speed forward or backward the video element probably perform a seek, so video is not playing and no glitch will be logged, the procedure that I normally use is to zoom in the trace to the point where video started playing back again. look for the threads from the video app that you are using and follow the readythreads to find what is causing video to not playback earlier.

    What app are you using? does it repro on any local content or with an specific content?

  • User profile image
    ScottHuang

    I am using the native video player on windows 10 mobile.  there does have a gab in "GPU decoding". so, I think you are right, because GPU don't have anything to decode. I will go analyzing the video app to figure out what's happening. thanks.

Add Your 2 Cents