<!DOCTYPE html>
<html class="no-js descriptionEmbedFormat_description" dir="ltr" lang="en">
	<head>

		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
		<title>Extensions in Visual Studio 2017 &#124; Visual Studio Toolbox &#124; Channel 9</title>
		<meta http-equiv="X-UA-Compatible" content="IE=edge">


		<meta name="viewport" content="width=device-width, initial-scale=1.0">

		<meta name="application-name" content="Channel 9">
		<meta name="msapplication-TileImage" content="/mstile-70x70.png">
		<meta name="msapplication-TileColor" content="#D2730D">
		<meta name="msapplication-config" content="/browserconfig.xml">
		<meta name="msapplication-task" content="name=Coffeehouse;action-uri=/forums/coffeehouse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Browse All Content;action-uri=/Browse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Shows;action-uri=/Browse/Shows;icon-uri=/favicon.ico">
		<meta name="apple-itunes-app" content="app-id=994423736">
		<link rel="manifest" href="/manifest.json">


		<link rel="shortcut icon" type="image/vnd.microsoft.icon" href="/favicon.ico">
		<link rel="apple-touch-icon" href="/favicon-129x129.png">
		

		<link rel="videothumbnail" type="image/jpeg" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_220.jpg"/>
		<link rel="image_src" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_220.jpg"/>
	<link rel="canonical" href="https://channel9.msdn.com/Shows/Visual-Studio-Toolbox/Extensions-in-Visual-Studio-2017"/>
	<link rel="alternate" type="application/rss+xml" href="/Shows/Visual-Studio-Toolbox/Extensions-in-Visual-Studio-2017/RSS" title="Extensions in Visual Studio 2017 Feed (Comments) - Channel 9"/>
	<meta name="description" content="In this episode, Robert is joined by Justin Clareburt, who shows us what users of extensions can expect in Visual Studio 2017. Justin first reviews the new setup experience, because that impacts exten"/>
	<meta name="keywords" content="Extensions,Visual Studio extensibility"/>
	<meta name="CommentCount" content="0"/>
	<meta property="og:title" content="Extensions in Visual Studio 2017"/>
	<meta property="og:description" content="In this episode, Robert is joined by Justin Clareburt, who shows us what users of extensions can expect in Visual Studio 2017. Justin first reviews the new setup experience, because that impacts exten"/>
	<meta property="og:type" content="video"/>
	<meta property="og:image" content="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_960.jpg"/>
	<meta property="og:image:secure_url" content="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_960.jpg"/>
	<meta property="og:url" content="https://channel9.msdn.com/Shows/Visual-Studio-Toolbox/Extensions-in-Visual-Studio-2017"/>
	<meta property="og:site_name" content="Channel 9"/>
		<meta property="og:video" content="http://video.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4"/>
		<meta property="og:video:secure_url" content="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4"/>
		<meta property="og:video:type" content="video/mp4"/>
		<meta property="og:video:width" content="512"/>
		<meta property="og:video:height" content="288"/>
		<meta name="twitter:card" content="player"/>
		<meta name="twitter:site" content="@ch9"/>
		<meta name="twitter:title" content="Extensions in Visual Studio 2017"/>
		<meta name="twitter:description" content="In this episode, Robert is joined by Justin Clareburt, who shows us what users of extensions can expect in Visual Studio 2017. Justin first reviews the new setup experience, because that impacts exten"/>
			<meta name="twitter:image:src" content="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_220.jpg"/>
		<meta name="twitter:player" content="https://channel9.msdn.com/Shows/Visual-Studio-Toolbox/Extensions-in-Visual-Studio-2017/player"/>
		<meta name="twitter:player:stream" content="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4"/>
		<meta name="twitter:player:stream:content_type" content="video/mp4"/>
		<meta name="twitter:player:height" content="288"/>
		<meta name="twitter:player:width" content="512"/>
	<script type="application/ld+json">{"@context":"http://schema.org","@type":"VideoObject","name":"Extensions in Visual Studio 2017","description":"In this episode, Robert is joined by Justin Clareburt, who shows us what users of extensions can expect in Visual Studio 2017. Justin&#160;first&#8230;","thumbnailUrl":"https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_960.jpg","uploadDate":"2017-02-09T16:40:51.3885598+00:00","duration":"PT00H32M31S","contentUrl":"https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4","embedUrl":"https://channel9.msdn.com/Shows/Visual-Studio-Toolbox/Extensions-in-Visual-Studio-2017/player"}</script>


		<link href="https://s.ch9.ms/c/global.css?v=1F9uxj2Z-CMDpAmetxoSQkOErhZDDRXkqShkzynnZ781" rel="stylesheet" type="text/css"/>
	<link href="https://s.ch9.ms/c/series.css?v=dWM65gr84KaG5I3JmoqGn7bRWv1o_600rXEIHf8PKrA1" rel="stylesheet" type="text/css"/>




		<script>
			var ch9 = ch9 || {data:{},functions:{},value:{}};
			ch9.value.CDNRoot='https://s.ch9.ms/';
		</script>

			<!--[if lt IE 9]>
				<script src="https://s.ch9.ms/j/ie8.js?v=8EwjwTmTL0-jc8hoKqU8RfJ_iLJ6Ss4xiXoSppqiHas1"></script>
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-1.12.0.min.js"></script>
			<![endif]-->
			<!--[if gte IE 9]><!-->
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-3.1.0.min.js"></script>
			<!--<![endif]-->

		<script>
			window.jQuery || document.write('<script src="/js/jquery/jquery-1.12.0.js"><\/script>')
		</script>
<script>
	if(!ch9){
		var ch9={data:{},functions:{},value:{}};
	}
	ch9.value.CDNRoot='https://s.ch9.ms/';
	ch9.value.rnd='-Q7hvPlhz2T73BmAVGqV1e83Lo41';
	ch9.data.culture = "en";
</script>
<!--[if lte IE 8]><script src="https://s.ch9.ms/js/global/iso8601parse.js?v=-Q7hvPlhz2T73BmAVGqV1e83Lo41"></script><![endif]-->


		
		<!--[if lt IE 7]><script>ch9.data.isIE6=true;</script><![endif]-->
		<script src="https://s.ch9.ms/j/global_en.js?v=-Q7hvPlhz2T73BmAVGqV1e83Lo41"></script>
		<script src="/j/strings/Js/en?callback=ch9.functions.Resources.ch9ResourcesCallback" type="text/javascript"></script>
	<script src="https://s.ch9.ms/j/series.js?v=-9D_WIUhisKk5W6awrrNwxRtt6M1ULH5jvGSNNnhErc1"></script>

	</head>

	<body class="episode hasVideo hasBanner" dir="ltr" data-guid="ee7657fb-5700-41b1-8557-a70800129c16" lang="en">
			
<header role="banner">
	<a tabindex="0" class="screenReader" href="#mainContent">Skip Navigation</a>
	<div class="navHolder holder">
		<nav class="container" role="navigation" aria-label="Main Navigation">
			<h1 class="screenReader">Primary Navigation</h1>

			<div class="brand">
				<a href="/" class="ch9Logo">
					<span class="ch9Name">Channel 9 Home</span>
				</a>
			</div>

			<button class="navigationToggle buttonTog" aria-pressed="false" aria-label="Toggle main navigation visibility">
				<span class="screenReader">
					Site Navigation
				</span>
			</button>

			<ul role="menubar" class="mainNavigation">
				<li>
					<a role="menuitem" href="/Browse/AllContent">All Content</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/AllShows">Shows</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/Events">Events</a>
				</li>
				<li>
					<a role="menuitem" href="/Forums">Forums</a>
				</li>
			</ul>

			<button class="searchToggle buttonTog" aria-pressed="false" aria-label="Toggle search form visibility">
				<span class="screenReader">
					Toggle Search
				</span>
			</button>

			<div class="siteSearch" role="complementary">
				<form class="bypassDirty" autocomplete="off" action="/Search" role="form">
					<label for="siteSearchText" class="screenReader">Search Channel 9</label>
					<input id="siteSearchText" type="text" name="term" placeholder="Search Channel 9" role="search"/>
					<label id="siteSearchButtonLabel" for="siteSearchButton">Search</label>
					<input id="siteSearchButton" type="submit" value="Search"/>
				</form>
			</div>

			<div class="userHolder">
					<a class="signInOut buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1486708542&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FVisual-Studio-Toolbox%2FExtensions-in-Visual-Studio-2017&amp;id=47159">Sign In</a>
			</div>
					
		</nav>
	</div>
</header>

<a class="screenReader" id="mainContent"></a>


	
	

<main role="main">
	<div class="itemHead holder" dir="ltr" lang="en">
		<div class="container">

			<div class="adminLinks">
					<div class="queueHolder">
							<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1486708542&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FVisual-Studio-Toolbox%2FExtensions-in-Visual-Studio-2017&amp;id=47159">Sign in to queue</a>
						<div class="queueError holder hidden">
							<div class="container">
								Sorry, an error occurred.
								<button class="close">
									<span class="screenReader">
										Close
									</span>
								</button>
							</div>
						</div>
					</div>
			</div>
			
			<div class="seriesTitle">
					<a href="/Shows/Visual-Studio-Toolbox">Visual Studio&#160;Toolbox</a>
			</div>
			<h1>Extensions in Visual Studio&#160;2017</h1>
			<ul class="metaData">
				<li class="episode group">
					<div class="releaseDate">
							<time class="timeHelper" data-message="This session is scheduled to begin Feb 09, 2017 at 8:40AM (UTC-08:00).
Based on your computer’s local time settings, this session is scheduled to begin Feb 09, 2017 at 4:40PM (UTC+00:00)." datetime="2017-02-09 16:40:51Z">Feb 09, 2017 at 8:40AM</time>
					</div>
					<div class="authors">
						by <a href="/Niners/rogreen">Robert Green</a>
					</div>
				</li>
				<li class="community group">
					<div class="rating">

<div class="ratingHolder" role="complementary">



		<a href="#" class="averageRating" title="Average of 0 out of 5 stars">
			<span style="width: 0%" itemtype="http://schema.org/AggregateRating" itemprop="aggregateRating">
				<span class="screenReader">
					Average of 0 out of 5 stars
				</span>
			</span>
		</a><span class="count">0</span> ratings

		<div class="signInToRate holder hidden">
			<div class="container">
				<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1486708542&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FVisual-Studio-Toolbox%2FExtensions-in-Visual-Studio-2017&amp;id=47159">Sign in to rate</a>
				<button class="close">
					<span class="screenReader">
						Close
					</span>
				</button>
			</div>
		</div>


</div>
					</div>
				</li>
			</ul>
		</div>
	</div>

	<div class="itemBody holder">
		<div class="container">
			



<style>
/* Video player
-------------------------------------------------- */

html.embedded {
	overflow: hidden;
}

html.embedded body.hasVideo {
	height: 100%;
	width: 100%;
}

.playerContainer {
	clear: both;
	font-family: segoe-ui_normal, 'Segoe UI', Segoe, 'Segoe WP', Tahoma, Verdana, Arial, sans-serif;
	height: 100%;
	position: relative;
	width: 100%;
}

.playerContainer a.video {
	background-position: center center;
	background-repeat: no-repeat;
	background-size: cover;
	display: block;
	height: 100%;
    position: relative;
	width: 100%;
}

.playerContainer a.video:before {
	content: "";
	display: block;
	padding-top: 56.25%;
}

.playerContainer a.video:active,
.playerContainer a.video:hover {
	text-decoration: none;
}

.playerContainer a.video .caption {
	background-color: rgba(0, 0, 0, .75);
	bottom: 0;
	color: #fff;
	display: block;
	font-size: 1.1rem;
	padding: 2% 4%;
	position: absolute;
}

body[dir=ltr] .playerContainer a.video .caption {
	left: 0;
}

body[dir=rtl] .playerContainer a.video .caption {
	right: 0;
}

.playerContainer > .video > .play {
	background-position: center center;
	background-repeat: no-repeat;
	background-size: cover;
	display: block;
	font-size: 0;
	overflow: hidden;
	padding-top: 56.25%;
	position: absolute;
	text-indent: -9999px;
	top: 0;
	width: 100% !important;
	z-index: 9;
}

.playerContainer > .video > .play:before {
	background-color: rgba(0, 0, 0, .5);
	border: 2px solid rgba(0, 0, 0, .2);
	border-radius: 8px;
	bottom: 0;
	color: transparent;
	content: "";
	cursor: pointer;
	display: inline-block;
	height: 16%;
	left: 0;
	margin: auto;
	position: absolute;
	right: 0;
	text-indent: -9999px;
	top: 0;
	transition: background-color 200ms ease 0s;
	width: 9%;
	z-index: 10;
}

.playerContainer > .video:focus > .play:before {
	outline: 2px solid #004e8e;
}

.playerContainer > .video > .play:after {
	background-image: url('data:image/png;base64,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');
}

.playerContainer > .video > .play:after {
	background-position: right center;
	background-repeat: no-repeat;
	bottom: 0;
	content: "";
	display: inline-block;
	left: 1.3%;
	position: absolute;
	right: 0;
	top: 0;
	width: 4.5%;
	height: 16.215%;
	margin: auto;
	z-index: 11;
}

.playerContainer.noVideo > .video > .play:before,
.playerContainer.noVideo > .video > .play:after {
	display: none;
}

.playerContainer > .video > .play:hover:before {
	background-color: rgba(0, 0, 0, 0.9);
	color: transparent;
}

.playerContainer .progress.circles {
	background-color: transparent;
	border: none;
}

.playerContainer .playerGoesHere {
	background-color: #fff;
	display: none;
	height: 100%;
	width: 100%;
   
}

.playerContainer video.Player {
	height: 100%;
	width: 100%;
}

.playerContainer .playerGoesHere.fullscreen {
	height: 100%;
	left: 0;
	overflow: hidden;
	position: fixed;
	top: 0;
	width: 100%;
	z-index: 9999;
}

.playerContainer ul.mediaformat,
.playerContainer ul.mediacaptions {
	display: none;
}

.playerContainer .error {
	color: #fff;
	font-size: 115%;
	padding: 15px;
	vertical-align: middle;
}

.playerContainer .error h3 {
	font-size: 120%;
}
</style>
<style>
	body {
		margin: 0;
		padding: 0;
	}
</style>

	<div class="playerContainer" style="" dir="ltr" lang="en">
		<a class="video" style="background-image:url(https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_960.jpg);" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4" title="Play" data-user='{
				"isLoggedIn": "False",
				"c9Id": "9a8394aae9e544e2b31db0e84d9882fa",
				"mrcId": "",
				"progress": ""
			}' data-player='{
				"playerPreference": "",
				"language": "en",
				"isSecure": "True"
			}' data-episode='{
				"contentId": "ee7657fb-5700-41b1-8557-a70800129c16",
				"length": "00:32:31",
				"api": "/Entries(guid&#39;ee7657fb-5700-41b1-8557-a70800129c16&#39;)/",
				"relatedApi": "/Related?id=ee7657fb-5700-41b1-8557-a70800129c16",
				"isMVA": "False"
			}'>
			<div class="play">Play Extensions in Visual Studio 2017</div>
			<time class="caption" datetime="00:32:31">32:31</time>
		</a>
		<div class="playerGoesHere"></div>
		
		<ul class="progressive mediaformat">
			
	<li>
		<a rel="Mp4Med" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4"></a>
	</li>
		</ul>
		<ul class="html5 mediaformat">
			
	<li>
		<a rel="Mp4" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions.mp4"></a>
	</li>
	<li>
		<a rel="Mp4High" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_high.mp4"></a>
	</li>
	<li>
		<a rel="Mp4Med" href="https://sec.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4"></a>
	</li>
		</ul>
		
	</div>


			<div class="download">
				<div>
					<h2>Download this episode</h2>
					<label for="format" class="screenReader">Select format</label>
					<div>
						<select name="format" id="format" class="bypassDirty">
									<option value="http://video.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions.mp3" data-filename="Extensions-in-Visual-Studio-2017.mp3">
										MP3
									</option>
									<option value="http://video.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions.mp4" data-filename="Extensions-in-Visual-Studio-2017_low.mp4">
										Low Quality MP4
									</option>
									<option value="http://video.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_high.mp4" data-filename="Extensions-in-Visual-Studio-2017_high.mp4">
										High Quality MP4
									</option>
									<option value="http://video.ch9.ms/ch9/76fe/d5ba8597-53ee-4ac0-ae5c-98faa7e776fe/VSToolboxExtensions_mid.mp4" data-filename="Extensions-in-Visual-Studio-2017_mid.mp4">
										Mid Quality MP4
									</option>
						</select>
						<a class="buttonPri">Download Video</a>
					</div>
				</div>

			</div>

			<div class="ch9tabGroup descriptionEmbedFormat" data-ch9tab_group_name="descriptionEmbedFormat" role="tablist">
				<section class="ch9tab description" data-ch9tab_name="description">
					<h2 role="tab" tabindex="0">Description</h2>
					<div class="ch9tabContent" dir="ltr" lang="en" role="tabpanel">
						<p>In this episode, Robert is joined by <a href="https://twitter.com/justcla78">Justin Clareburt</a>, who shows us what users of extensions can expect in <a href="https://www.visualstudio.com/vs/visual-studio-2017-rc/">Visual Studio 2017</a>. Justin first reviews the new setup experience, because that impacts extensions. Among the things he shows are&nbsp;lightweight solution loading <a href="#time=07m35s">[07:35]</a>, how you can monitor the performance of extensions and see whether they are slowing you down <a href="#time=09m00s">[09:00]</a>, how extension builders can specify what Visual Studio components are required to run the extension <a href="#time=18m50s">[18:50]</a> and how to build an extension <a href="#time=24m45s">[24:45]</a>.</p><p>&nbsp;</p>

						<div class="details" dir="ltr" lang="en">
							<div class="tags">
								<h3>Tags:</h3>
								<a href="/Tags/extensions">Extensions</a><span>, </span><a href="/Tags/visual-studio-extensibility">Visual Studio extensibility</a>
							</div>
						</div>
					</div>
				</section>

				<section class="ch9tab share" data-ch9tab_name="share">
					<h2 role="tab" tabindex="0">Share</h2>
					<div class="ch9tabContent" role="tabpanel">
						<ul class="sharing">
							<li>
								<a target="_blank" href="https://twitter.com/intent/tweet/?text=Extensions+in+Visual+Studio+2017&url=https%3a%2f%2fchannel9.msdn.com%2fShows%2fVisual-Studio-Toolbox%2fExtensions-in-Visual-Studio-2017&via=ch9" class="twitter mediumIcon"><span class="screenReader">Twitter</span></a>
              				</li>
							<li>
								<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fchannel9.msdn.com%2fShows%2fVisual-Studio-Toolbox%2fExtensions-in-Visual-Studio-2017" class="facebook mediumIcon"><span class="screenReader">Facebook</span></a>
							</li>
							<li>
								<a target="_blank" href="http://www.reddit.com/submit?url=https%3a%2f%2fchannel9.msdn.com%2fShows%2fVisual-Studio-Toolbox%2fExtensions-in-Visual-Studio-2017" class="reddit mediumIcon"><span class="screenReader">Reddit</span></a>
							</li>
						</ul>
						<form class="ch9form bypassDirty">
							<fieldset>
								<label for="shareLink" class="screenReader">Share Link</label>
								<input type="text" id="shareLink" value="https://channel9.msdn.com/Shows/Visual-Studio-Toolbox/Extensions-in-Visual-Studio-2017"/>
								<input class="buttonPri copy" type="button" value="Copy"/>
							</fieldset>
						</form>
					</div>
				</section>

				<section class="ch9tab embed" data-ch9tab_name="embed">
					<h2 role="tab" tabindex="0">Embed</h2>
					<div class="ch9tabContent" role="tabpanel"></div>
				</section>

				<section class="ch9tab format" data-ch9tab_name="format">
					<h2 role="tab" tabindex="0">Format</h2>
					<div class="ch9tabContent" role="tabpanel">
						<h3>Available formats for this video:</h3>
						<p>Actual format may change based on video formats available and browser capability.</p>
						<ul class="formatTypes" data-selectedformat="auto"></ul>
					</div>
				</section>
			</div>
		</div>
	</div>

	<section class="moreEpisodes">
		<div class="container">
			<div class="holder">
					<h2>More episodes in this series</h2>
					

	
<article class="abstract xSmall" data-api="/Entries(guid&#39;cedd5c38-6f69-4eb3-9878-a6fa014d1aae&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Visual-Studio-Toolbox">Visual Studio&#160;Toolbox</a>
		</div>
		<h3>
			<a href="/Shows/Visual-Studio-Toolbox/Visual-Studio-Tools-for-Azure-Functions">Visual Studio Tools for Azure&#160;Functions</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Visual-Studio-Toolbox/Visual-Studio-Tools-for-Azure-Functions">
			<img role="img" src="https://sec.ch9.ms/ch9/124e/9fe2f2f3-248d-4014-8c6b-fcd2eced124e/VSToolboxAzureFunctionsUPDATE_512.jpg" alt="Visual Studio Tools for Azure Functions"/>
			<time class="caption" datetime="00:35:46">35:46</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;874b703d-30c7-4a73-ba83-a708013073d2&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Visual-Studio-Toolbox">Visual Studio&#160;Toolbox</a>
		</div>
		<h3>
			<a href="/Shows/Visual-Studio-Toolbox/Entity-Framework-Core">Entity Framework&#160;Core</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Visual-Studio-Toolbox/Entity-Framework-Core">
			<img role="img" src="https://sec.ch9.ms/ch9/5232/8d9f1019-3beb-4b9c-8f71-6e5e08c15232/VSToolboxEntityFrameworkCore_512.jpg" alt="Entity Framework Core"/>
			<time class="caption" datetime="01:17:19">01:17:19</time>
	</a>
</article>

					<h2>Related episodes</h2>
					

	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;ae98097a-ec8f-4806-a313-a485012f7003&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/TFS-Auto-Shelve-for-Visual-Studio-2015-and-2013-2012-Extension">TFS Auto Shelve for Visual Studio 2015 (and 2013, 2012)&#160;Extension</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/TFS-Auto-Shelve-for-Visual-Studio-2015-and-2013-2012-Extension">
			<img role="img" src="https://f.ch9.ms/thumbnail/214c81ba-f5a1-44cf-bad7-13731ba60ac2.png" alt="TFS Auto Shelve for Visual Studio 2015 (and 2013, 2012) Extension"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;359772ff-752f-4484-a9c4-a2d3015c8a21&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/F3-is-so-yesterday-The-Sando-Visual-Studio-Extension-provides-real-code-indexing-search-and-more">F3 is so yesterday... The Sando Visual Studio Extension provides real code&#160;indexing,&#8230;</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/F3-is-so-yesterday-The-Sando-Visual-Studio-Extension-provides-real-code-indexing-search-and-more">
			<img role="img" src="https://f.ch9.ms/thumbnail/5b0d15b9-5cbe-46a7-ae67-3fb3c8dc936b.png" alt="F3 is so yesterday... The Sando Visual Studio Extension provides real code indexing, search and more"/>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;874b703d-30c7-4a73-ba83-a708013073d2&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Visual-Studio-Toolbox">Visual Studio&#160;Toolbox</a>
		</div>
		<h3>
			<a href="/Shows/Visual-Studio-Toolbox/Entity-Framework-Core">Entity Framework&#160;Core</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Visual-Studio-Toolbox/Entity-Framework-Core">
			<img role="img" src="https://sec.ch9.ms/ch9/5232/8d9f1019-3beb-4b9c-8f71-6e5e08c15232/VSToolboxEntityFrameworkCore_512.jpg" alt="Entity Framework Core"/>
			<time class="caption" datetime="01:17:19">01:17:19</time>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;123e7c2e-2640-4275-92cf-a7020121f599&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Productivity-Power-Tools-Pack-2017-Now-Available">Productivity Power [Tools] Pack 2017 Now&#160;Available!</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Productivity-Power-Tools-Pack-2017-Now-Available">
			<img role="img" src="https://f.ch9.ms/thumbnail/43cbc11a-b94b-4f82-9898-4704d383b760.png" alt="Productivity Power [Tools] Pack 2017 Now Available!"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;494dd62d-68b3-4f6b-8c41-a6fb012a5c22&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Its-Time-to-Update-Your-VS-2017-Extension-Manifest">It's Time to Update Your VS 2017 Extension&#160;Manifest</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Its-Time-to-Update-Your-VS-2017-Extension-Manifest">
			<img role="img" src="https://f.ch9.ms/thumbnail/4b5a0794-70d0-4412-9e36-2e2d6ed677e5.png" alt="It&#39;s Time to Update Your VS 2017 Extension Manifest"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;234288a5-db76-4f0b-a22f-a6ec01347306&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Writing-Visual-Studio-2015-Extensions-Youll-want-these-Templates">Writing Visual Studio 2015 Extensions? You’ll want these&#160;Templates…</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Writing-Visual-Studio-2015-Extensions-Youll-want-these-Templates">
			<img role="img" src="https://f.ch9.ms/thumbnail/4aa3ed2d-e7fd-4fe3-90a9-032f87f0eb86.png" alt="Writing Visual Studio 2015 Extensions? You’ll want these Templates…"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;0f11f2c0-568a-41ab-837e-a6e601135a55&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Time-Savers-the-Definition-of-a-VS-Extension">Time Savers, the Definition of a VS&#160;Extension</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Time-Savers-the-Definition-of-a-VS-Extension">
			<img role="img" src="https://f.ch9.ms/thumbnail/07bd2771-6236-475e-acb2-979d8f20ec06.png" alt="Time Savers, the Definition of a VS Extension"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;40e3c83f-378b-4a98-8c63-a6df017457bb&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/VS-Macro-Magic-How-To">VS Macro Magic How&#160;To</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/VS-Macro-Magic-How-To">
			<img role="img" src="https://f.ch9.ms/thumbnail/b123a83c-9600-42c5-a850-e4554f15da1c.png" alt="VS Macro Magic How To"/>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;257d498d-05a9-44ad-88f6-a6d501666102&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Visual-Studio-Toolbox">Visual Studio&#160;Toolbox</a>
		</div>
		<h3>
			<a href="/Shows/Visual-Studio-Toolbox/Exploring-our-newest-sample-app-BikeSharing360">Exploring our newest sample app,&#160;BikeSharing360</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Visual-Studio-Toolbox/Exploring-our-newest-sample-app-BikeSharing360">
			<img role="img" src="https://sec.ch9.ms/ch9/1737/3933d2c7-b954-4538-a5e5-f3a710921737/BikeSharing360_512.jpg" alt="Exploring our newest sample app, BikeSharing360"/>
			<time class="caption" datetime="00:41:48">41:48</time>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;a2dbb99e-55bf-44e1-a125-a6d80147f53b&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Dial-into-Debugging-with-the-Surface-Dial">Dial into Debugging with the Surface&#160;Dial</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Dial-into-Debugging-with-the-Surface-Dial">
			<img role="img" src="https://f.ch9.ms/thumbnail/67762a29-5a75-4097-953a-72b7fc32ebf0.png" alt="Dial into Debugging with the Surface Dial"/>
	</a>
</article>

			</div>
		</div>
	</section>

	<section class="followTheDiscussion">
	
		<div class="container">
			<div class="holder">
				<div class="commentLinks">
				</div>
				<h2>The Discussion</h2>
			
				<ul class="discussion" id="comments">
				</ul>
				
				

						<!-- this form is for not signed in users -->
						<form method="post" id="commentState" class="ch9form discussion episode" autocomplete="off">
							
							<fieldset id="commentForm">
								<h2>Add Your 2 Cents</h2>
								<ul class="clearfix">
									<li>
										<label class="subject" for="CommentState_Subject">Are you human? If so, leave this field blank.</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.Subject" data-valmsg-replace="true"></span>
										<input class="subject" id="CommentState_Subject" name="CommentState.Subject" type="text" value="" />
									</li>
									<li>
										<label for="CommentState_AnonymousUser_DisplayName">Name</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.DisplayName" data-valmsg-replace="true"></span>
										<input data-val="true" data-val-regex="Please enter a name with only letters, numbers, and spaces" data-val-regex-pattern="[A-Za-z0-9][A-Za-z 0-9]+[A-Za-z0-9]" data-val-required="Name field is required" id="CommentState_AnonymousUser_DisplayName" name="CommentState.AnonymousUser.DisplayName" type="text" value="" />
									</li>
									<li>
										<label for="CommentState_AnonymousUser_Email">Email</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.Email" data-valmsg-replace="true"></span>
										<input data-val="true" data-val-email="Please enter your email address in the format someone@example.com" data-val-required="Email address is required" id="CommentState_AnonymousUser_Email" name="CommentState.AnonymousUser.Email" type="text" value="" />
									</li>
									<li class="sign-in">
										<span class="conjunction">Or</span>
										<a class="buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1486708542&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FVisual-Studio-Toolbox%2FExtensions-in-Visual-Studio-2017&amp;id=47159">Sign In</a>
									</li>
									<li>
										<label for="CommentState_AnonymousBody">Comment</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousBody" data-valmsg-replace="true"></span>
										<textarea class="comment" cols="100" data-val="true" data-val-requireone="Comment field is required." data-val-requireone-otherpropertyname="AuthenticatedBody" id="CommentState_AnonymousBody" name="CommentState.AnonymousBody" rows="10">
</textarea>
									</li>
									<li>
										<input name="__RequestVerificationToken" type="hidden" value="mna81lv-y6SLsmDuATq3KPHaPw8YVNDIKVbRh6EqSm_nxWdzKq23U8guxSzGSrsm0A5aNKTf-Oncc_WhuNoA2WoURL41" />
										<input type="submit" value="Comment" class="buttonPri"/>
									</li>
								</ul>
							</fieldset>
						</form>
			</div>
		</div>
	
	</section>

</main>



<footer role="contentinfo">
	<div class="container">

		<ul class="sharing">
			<li>
				<a href="/ContactUs" class="email mediumIcon"><span class="screenReader">Email</span></a>
			</li>
			<li>
				<a href="https://twitter.com/ch9" class="twitter mediumIcon"><span class="screenReader">Twitter</span></a>
			</li>
			<li>
				<a href="https://www.facebook.com/msftchannel9" class="facebook mediumIcon"><span class="screenReader">Facebook</span></a>
			</li>
			<li>
				<a href="https://s.ch9.ms/Feeds/RSS" class="rss mediumIcon"><span class="screenReader">RSS</span></a>
			</li>
		</ul>

		<ul class="otherLinks">
			<li>
				<a href="/About">About</a>
			</li>
			<li>
				<a href="/Browse/Authors?direction=desc">Authors</a>
			</li>
			<li>
				<a href="/Events/Speakers?direction=desc">Speakers</a>
			</li>
			<li>
				<a href="/Browse/Tags?letter=A">Tags</a>
			</li>
			<li>
				<a href="/ContactUs">Contact Us</a>
			</li>
			<li>
				<a href="/localization/chrome?returnUrl=%252fShows%252fVisual-Studio-Toolbox%252fExtensions-in-Visual-Studio-2017">
					English
				</a>
			</li>
			<li>
				<a href="/CodeOfConduct">Code of Conduct</a>
			</li>
			<li>
				<a href="http://go.microsoft.com/?linkid=4412892">Terms of Service</a>
			</li>
			<li>
				<a href="http://www.microsoft.com/privacystatement/en-us/Channel9App/Default.aspx">Privacy Statement</a>
			</li>
		</ul>

		<p class="copyright">
			&copy; 2017 Microsoft. <wbr>Microsoft reserves all rights associated with the materials on this site.
		</p>
	</div>
</footer>
			
		
		<!-- Host Location: channel9website -->
		<!-- non-realtime scripts. ALL external scripts must be lazy loaded -->
		<!-- Tracking scripts. Social media scripts for facebook, twitter, new relic, web trends -->
			<script src="//tags.tiqcdn.com/utag/msft/ch9/prod/utag.js"></script>
	</body>
</html>