<!DOCTYPE html>
<html class="no-js descriptionEmbedFormat_description" dir="ltr" lang="en">
	<head>

		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
		<title>Custom Speech Service and Beezy &#124; Web Hack Wednesday &#124; Channel 9</title>
		<meta http-equiv="X-UA-Compatible" content="IE=edge">


		<meta name="viewport" content="width=device-width, initial-scale=1.0">

		<meta name="application-name" content="Channel 9">
		<meta name="msapplication-TileImage" content="/mstile-70x70.png">
		<meta name="msapplication-TileColor" content="#D2730D">
		<meta name="msapplication-config" content="/browserconfig.xml">
		<meta name="msapplication-task" content="name=Coffeehouse;action-uri=/forums/coffeehouse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Browse All Content;action-uri=/Browse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Shows;action-uri=/Browse/Shows;icon-uri=/favicon.ico">
		<meta name="apple-itunes-app" content="app-id=994423736">
		<link rel="manifest" href="/manifest.json">


		<link rel="shortcut icon" type="image/vnd.microsoft.icon" href="/favicon.ico">
		<link rel="apple-touch-icon" href="/favicon-129x129.png">
		

		<link rel="videothumbnail" type="image/jpeg" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_220.jpg"/>
		<link rel="image_src" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_220.jpg"/>
	<link rel="canonical" href="https://channel9.msdn.com/Shows/Web-Hack-Wednesday/Custom-Speech-Service-and-Beezy"/>
	<link rel="alternate" type="application/rss+xml" href="/Shows/Web-Hack-Wednesday/Custom-Speech-Service-and-Beezy/RSS" title="Custom Speech Service and Beezy Feed (Comments) - Channel 9"/>
	<meta name="description" content="Martin and Martin look at the Custom Speech Service and how it was used in a bot project that Martin Beeby worked on with a company called Beezy. The Custom Speech service allows developers to train a"/>
	<meta name="keywords" content="Web,Artificial Intelligence"/>
	<meta name="CommentCount" content="0"/>
	<meta property="og:title" content="Custom Speech Service and Beezy"/>
	<meta property="og:description" content="Martin and Martin look at the Custom Speech Service and how it was used in a bot project that Martin Beeby worked on with a company called Beezy. The Custom Speech service allows developers to train a"/>
	<meta property="og:type" content="video"/>
	<meta property="og:image" content="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_960.jpg"/>
	<meta property="og:image:secure_url" content="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_960.jpg"/>
	<meta property="og:url" content="https://channel9.msdn.com/Shows/Web-Hack-Wednesday/Custom-Speech-Service-and-Beezy"/>
	<meta property="og:site_name" content="Channel 9"/>
		<meta property="og:video" content="http://video.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4"/>
		<meta property="og:video:secure_url" content="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4"/>
		<meta property="og:video:type" content="video/mp4"/>
		<meta property="og:video:width" content="512"/>
		<meta property="og:video:height" content="288"/>
		<meta name="twitter:card" content="player"/>
		<meta name="twitter:site" content="@ch9"/>
		<meta name="twitter:title" content="Custom Speech Service and Beezy"/>
		<meta name="twitter:description" content="Martin and Martin look at the Custom Speech Service and how it was used in a bot project that Martin Beeby worked on with a company called Beezy. The Custom Speech service allows developers to train a"/>
			<meta name="twitter:image:src" content="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_220.jpg"/>
		<meta name="twitter:player" content="https://channel9.msdn.com/Shows/Web-Hack-Wednesday/Custom-Speech-Service-and-Beezy/player"/>
		<meta name="twitter:player:stream" content="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4"/>
		<meta name="twitter:player:stream:content_type" content="video/mp4"/>
		<meta name="twitter:player:height" content="288"/>
		<meta name="twitter:player:width" content="512"/>
	<script type="application/ld+json">{"@context":"http://schema.org","@type":"VideoObject","name":"Custom Speech Service and Beezy","description":"Martin and Martin look at the Custom Speech Service and how it was used in a bot project that Martin Beeby worked on with a company&#160;called&#8230;","thumbnailUrl":"https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_960.jpg","uploadDate":"2017-03-16T15:20:42.5656471+00:00","duration":"PT00H23M21S","contentUrl":"https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4","embedUrl":"https://channel9.msdn.com/Shows/Web-Hack-Wednesday/Custom-Speech-Service-and-Beezy/player"}</script>


		<link href="https://s.ch9.ms/c/global.css?v=0cnhBeRp9MhDaKvpwLdOUabwjllBMxxfRiaFECe5KL81" rel="stylesheet" type="text/css"/>
	<link href="https://s.ch9.ms/c/series.css?v=dWM65gr84KaG5I3JmoqGn7bRWv1o_600rXEIHf8PKrA1" rel="stylesheet" type="text/css"/>




		<script>
			var ch9 = ch9 || {data:{},functions:{},value:{}};
			ch9.value.CDNRoot='https://s.ch9.ms/';
		</script>

			<!--[if lt IE 9]>
				<script src="https://s.ch9.ms/j/ie8.js?v=8EwjwTmTL0-jc8hoKqU8RfJ_iLJ6Ss4xiXoSppqiHas1"></script>
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-1.12.0.min.js"></script>
			<![endif]-->
			<!--[if gte IE 9]><!-->
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-3.1.0.min.js"></script>
			<!--<![endif]-->

		<script>
			window.jQuery || document.write('<script src="/js/jquery/jquery-1.12.0.js"><\/script>')
		</script>
<script>
	if(!ch9){
		var ch9={data:{},functions:{},value:{}};
	}
	ch9.value.CDNRoot='https://s.ch9.ms/';
	ch9.value.rnd='rdYja4UFrbXFy4La8W7drT-j8g41';
	ch9.data.culture = "en";
</script>
<!--[if lte IE 8]><script src="https://s.ch9.ms/js/global/iso8601parse.js?v=rdYja4UFrbXFy4La8W7drT-j8g41"></script><![endif]-->


		
		<!--[if lt IE 7]><script>ch9.data.isIE6=true;</script><![endif]-->
		<script src="https://s.ch9.ms/j/global_en.js?v=rdYja4UFrbXFy4La8W7drT-j8g41"></script>
		<script src="/j/strings/Js/en?callback=ch9.functions.Resources.ch9ResourcesCallback" type="text/javascript"></script>
	<script src="https://s.ch9.ms/j/series.js?v=OmyjiIOqY9zvLv2FN0rG7hrzJyxShQkfaJjWj24w0K01"></script>

	</head>

	<body class="episode hasVideo hasBanner" dir="ltr" data-guid="2655d644-ab83-408e-9dcf-a737017d9ea7" lang="en">
			
<header role="banner">
	<a tabindex="0" class="screenReader" href="#mainContent">Skip Navigation</a>
	<div class="navHolder holder">
		<nav class="container" role="navigation" aria-label="Main Navigation">
			<h1 class="screenReader">Primary Navigation</h1>

			<div class="brand">
				<a href="/" class="ch9Logo">
					<span class="ch9Name">Channel 9 Home</span>
				</a>
			</div>

			<button class="navigationToggle buttonTog" aria-pressed="false" aria-label="Toggle main navigation visibility">
				<span class="screenReader">
					Site Navigation
				</span>
			</button>

			<ul role="menubar" class="mainNavigation">
				<li>
					<a role="menuitem" href="/Browse/AllContent">All Content</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/AllShows">Shows</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/Events">Events</a>
				</li>
				<li>
					<a role="menuitem" href="/Forums">Forums</a>
				</li>
			</ul>

			<button class="searchToggle buttonTog" aria-pressed="false" aria-label="Toggle search form visibility">
				<span class="screenReader">
					Toggle Search
				</span>
			</button>

			<div class="siteSearch" role="complementary">
				<form class="bypassDirty" autocomplete="off" action="/Search" role="form">
					<label for="siteSearchText" class="screenReader">Search Channel 9</label>
					<input id="siteSearchText" type="text" name="term" placeholder="Search Channel 9" role="search"/>
					<label id="siteSearchButtonLabel" for="siteSearchButton">Search</label>
					<input id="siteSearchButton" type="submit" value="Search"/>
				</form>
			</div>

			<div class="userHolder">
					<a class="signInOut buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1489689450&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FWeb-Hack-Wednesday%2FCustom-Speech-Service-and-Beezy&amp;id=47159">Sign In</a>
			</div>
					
		</nav>
	</div>
</header>

<a class="screenReader" id="mainContent"></a>


	
	

<main role="main">
	<div class="itemHead holder" dir="ltr" lang="en">
		<div class="container">

			<div class="adminLinks">
					<div class="queueHolder">
							<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1489689450&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FWeb-Hack-Wednesday%2FCustom-Speech-Service-and-Beezy&amp;id=47159">Sign in to queue</a>
						<div class="queueError holder hidden">
							<div class="container">
								Sorry, an error occurred.
								<button class="close">
									<span class="screenReader">
										Close
									</span>
								</button>
							</div>
						</div>
					</div>
			</div>
			
			<div class="seriesTitle">
					<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
			</div>
			<h1>Custom Speech Service and&#160;Beezy</h1>
			<ul class="metaData">
				<li class="episode group">
					<div class="releaseDate">
							<time class="timeHelper" data-message="This session is scheduled to begin Mar 16, 2017 at 8:20AM (UTC-07:00).
Based on your computer’s local time settings, this session is scheduled to begin Mar 16, 2017 at 3:20PM (UTC+00:00)." datetime="2017-03-16 15:20:42Z">Mar 16, 2017 at 8:20AM</time>
					</div>
					<div class="authors">
						by <a href="/Niners/thebeebs">thebeebs</a><span>, </span><a href="/Niners/MartinKearn">Martin Kearn</a>
					</div>
				</li>
				<li class="community group">
					<div class="rating">

<div class="ratingHolder" role="complementary">



		<a href="#" class="averageRating" title="Average of 0 out of 5 stars">
			<span style="width: 0%" itemtype="http://schema.org/AggregateRating" itemprop="aggregateRating">
				<span class="screenReader">
					Average of 0 out of 5 stars
				</span>
			</span>
		</a><span class="count">0</span> ratings

		<div class="signInToRate holder hidden">
			<div class="container">
				<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1489689450&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FWeb-Hack-Wednesday%2FCustom-Speech-Service-and-Beezy&amp;id=47159">Sign in to rate</a>
				<button class="close">
					<span class="screenReader">
						Close
					</span>
				</button>
			</div>
		</div>


</div>
					</div>
				</li>
			</ul>
		</div>
	</div>

	<div class="itemBody holder">
		<div class="container">
			



<style>
/* Video player
-------------------------------------------------- */

html.embedded {
	overflow: hidden;
}

html.embedded body.hasVideo {
	height: 100%;
	width: 100%;
}

.playerContainer {
	clear: both;
	font-family: segoe-ui_normal, 'Segoe UI', Segoe, 'Segoe WP', Tahoma, Verdana, Arial, sans-serif;
	height: 100%;
	position: relative;
	width: 100%;
}

.playerContainer a.video {
	background-position: center center;
	background-repeat: no-repeat;
	background-size: cover;
	display: block;
	height: 100%;
    position: relative;
	width: 100%;
}

.playerContainer a.video:before {
	content: "";
	display: block;
	padding-top: 56.25%;
}

.playerContainer a.video:active,
.playerContainer a.video:hover {
	text-decoration: none;
}

.playerContainer a.video .caption {
	background-color: rgba(0, 0, 0, .75);
	bottom: 0;
	color: #fff;
	display: block;
	font-size: 1.1rem;
	padding: 2% 4%;
	position: absolute;
}

body[dir=ltr] .playerContainer a.video .caption {
	left: 0;
}

body[dir=rtl] .playerContainer a.video .caption {
	right: 0;
}

.playerContainer > .video > .play {
	background-position: center center;
	background-repeat: no-repeat;
	background-size: cover;
	display: block;
	font-size: 0;
	overflow: hidden;
	padding-top: 56.25%;
	position: absolute;
	text-indent: -9999px;
	top: 0;
	width: 100% !important;
	z-index: 9;
}

.playerContainer > .video > .play:before {
	background-color: rgba(0, 0, 0, .5);
	border: 2px solid rgba(0, 0, 0, .2);
	border-radius: 8px;
	bottom: 0;
	color: transparent;
	content: "";
	cursor: pointer;
	display: inline-block;
	height: 16%;
	left: 0;
	margin: auto;
	position: absolute;
	right: 0;
	text-indent: -9999px;
	top: 0;
	transition: background-color 200ms ease 0s;
	width: 9%;
	z-index: 10;
}

.playerContainer > .video:focus > .play:before {
	outline: 2px solid #004e8e;
}

.playerContainer > .video > .play:after {
	background-image: url('data:image/png;base64,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');
}

.playerContainer > .video > .play:after {
	background-position: right center;
	background-repeat: no-repeat;
	bottom: 0;
	content: "";
	display: inline-block;
	left: 1.3%;
	position: absolute;
	right: 0;
	top: 0;
	width: 4.5%;
	height: 16.215%;
	margin: auto;
	z-index: 11;
}

.playerContainer.noVideo > .video > .play:before,
.playerContainer.noVideo > .video > .play:after {
	display: none;
}

.playerContainer > .video > .play:hover:before {
	background-color: rgba(0, 0, 0, 0.9);
	color: transparent;
}

.playerContainer .progress.circles {
	background-color: transparent;
	border: none;
}

.playerContainer .playerGoesHere {
	background-color: #fff;
	display: none;
	height: 100%;
	width: 100%;
   
}

.playerContainer video.Player {
	height: 100%;
	width: 100%;
}

.playerContainer .playerGoesHere.fullscreen {
	height: 100%;
	left: 0;
	overflow: hidden;
	position: fixed;
	top: 0;
	width: 100%;
	z-index: 9999;
}

.playerContainer ul.mediaformat,
.playerContainer ul.mediacaptions {
	display: none;
}

.playerContainer .error {
	color: #fff;
	font-size: 115%;
	padding: 15px;
	vertical-align: middle;
}

.playerContainer .error h3 {
	font-size: 120%;
}
</style>
<style>
	body {
		margin: 0;
		padding: 0;
	}
</style>

	<div class="playerContainer" style="" dir="ltr" lang="en">
		<a class="video" style="background-image:url(https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_960.jpg);" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4" title="Play" data-user='{
				"isLoggedIn": "False",
				"c9Id": "abeebc86458346ef8381118a8de812dc",
				"mrcId": "",
				"progress": ""
			}' data-player='{
				"playerPreference": "",
				"language": "en",
				"isSecure": "True"
			}' data-episode='{
				"contentId": "2655d644-ab83-408e-9dcf-a737017d9ea7",
				"length": "00:23:21",
				"api": "/Entries(guid&#39;2655d644-ab83-408e-9dcf-a737017d9ea7&#39;)/",
				"relatedApi": "/Related?id=2655d644-ab83-408e-9dcf-a737017d9ea7",
				"isMVA": "False"
			}'>
			<div class="play">Play Custom Speech Service and Beezy</div>
			<time class="caption" datetime="00:23:21">23:21</time>
		</a>
		<div class="playerGoesHere"></div>
		
		<ul class="progressive mediaformat">
			
	<li>
		<a rel="Mp4Med" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4"></a>
	</li>
		</ul>
		<ul class="html5 mediaformat">
			
	<li>
		<a rel="Mp4" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris.mp4"></a>
	</li>
	<li>
		<a rel="Mp4High" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_high.mp4"></a>
	</li>
	<li>
		<a rel="Mp4Med" href="https://sec.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4"></a>
	</li>
		</ul>
		
	</div>


			<div class="download">
				<div>
					<h2>Download this episode</h2>
					<label for="format" class="screenReader">Select format</label>
					<div>
						<select name="format" id="format" class="bypassDirty">
									<option value="http://video.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris.mp3" data-filename="Custom-Speech-Service-and-Beezy.mp3">
										MP3
									</option>
									<option value="http://video.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris.mp4" data-filename="Custom-Speech-Service-and-Beezy_low.mp4">
										Low Quality MP4
									</option>
									<option value="http://video.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_high.mp4" data-filename="Custom-Speech-Service-and-Beezy_high.mp4">
										High Quality MP4
									</option>
									<option value="http://video.ch9.ms/ch9/9071/168dc139-eeac-47e2-8ab7-b28eadff9071/whws2e9Cris_mid.mp4" data-filename="Custom-Speech-Service-and-Beezy_mid.mp4">
										Mid Quality MP4
									</option>
						</select>
						<a class="buttonPri">Download Video</a>
					</div>
				</div>

			</div>

			<div class="ch9tabGroup descriptionEmbedFormat" data-ch9tab_group_name="descriptionEmbedFormat" role="tablist">
				<section class="ch9tab description" data-ch9tab_name="description">
					<h2 role="tab" tabindex="0">Description</h2>
					<div class="ch9tabContent" dir="ltr" lang="en" role="tabpanel">
						<p>Martin and Martin look at the Custom Speech Service and how it was used in a bot project that Martin Beeby worked on with a company called Beezy. The Custom Speech service allows developers to train a speech recognition engine to specific language data and acoustic models to improve accuracy when used within a website or app.</p>

						<div class="details" dir="ltr" lang="en">
							<div class="tags">
								<h3>Tags:</h3>
								<a href="/Tags/web">Web</a><span>, </span><a href="/Tags/artificial+intelligence">Artificial Intelligence</a>
							</div>
						</div>
					</div>
				</section>

				<section class="ch9tab share" data-ch9tab_name="share">
					<h2 role="tab" tabindex="0">Share</h2>
					<div class="ch9tabContent" role="tabpanel">
						<ul class="sharing">
							<li>
								<a target="_blank" href="https://twitter.com/intent/tweet/?text=Custom+Speech+Service+and+Beezy&url=https%3a%2f%2fchannel9.msdn.com%2fShows%2fWeb-Hack-Wednesday%2fCustom-Speech-Service-and-Beezy&via=ch9" class="twitter mediumIcon"><span class="screenReader">Twitter</span></a>
              				</li>
							<li>
								<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fchannel9.msdn.com%2fShows%2fWeb-Hack-Wednesday%2fCustom-Speech-Service-and-Beezy" class="facebook mediumIcon"><span class="screenReader">Facebook</span></a>
							</li>
							<li>
								<a target="_blank" href="http://www.reddit.com/submit?url=https%3a%2f%2fchannel9.msdn.com%2fShows%2fWeb-Hack-Wednesday%2fCustom-Speech-Service-and-Beezy" class="reddit mediumIcon"><span class="screenReader">Reddit</span></a>
							</li>
						</ul>
						<form class="ch9form bypassDirty">
							<fieldset>
								<label for="shareLink" class="screenReader">Share Link</label>
								<input type="text" id="shareLink" value="https://channel9.msdn.com/Shows/Web-Hack-Wednesday/Custom-Speech-Service-and-Beezy"/>
								<input class="buttonPri copy" type="button" value="Copy"/>
							</fieldset>
						</form>
					</div>
				</section>

				<section class="ch9tab embed" data-ch9tab_name="embed">
					<h2 role="tab" tabindex="0">Embed</h2>
					<div class="ch9tabContent" role="tabpanel"></div>
				</section>

				<section class="ch9tab format" data-ch9tab_name="format">
					<h2 role="tab" tabindex="0">Format</h2>
					<div class="ch9tabContent" role="tabpanel">
						<h3>Available formats for this video:</h3>
						<p>Actual format may change based on video formats available and browser capability.</p>
						<ul class="formatTypes" data-selectedformat="auto"></ul>
					</div>
				</section>
			</div>
		</div>
	</div>

	<section class="moreEpisodes">
		<div class="container">
			<div class="holder">
					<h2>More episodes in this series</h2>
					

	
<article class="abstract xSmall" data-api="/Entries(guid&#39;19fae751-9968-4037-9485-a72200cb7eca&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Web-Notification-API">Web Notification&#160;API</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Web-Notification-API">
			<img role="img" src="https://sec.ch9.ms/ch9/7de4/655cf461-00ff-4880-89a3-546bc81f7de4/whwS2E8Notificationsv2_512.jpg" alt="Web Notification API"/>
			<time class="caption" datetime="00:14:09">14:09</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;b20240c2-f3a7-4ee3-a7e3-a72900d416ac&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Web-Audio">Web&#160;Audio</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Web-Audio">
			<img role="img" src="https://sec.ch9.ms/ch9/d60f/810bb450-3b98-4033-ac6b-4f4e53b1d60f/whws2e8WebAudio_512.jpg" alt="Web Audio"/>
			<time class="caption" datetime="00:14:09">14:09</time>
	</a>
</article>

					<h2>Related episodes</h2>
					

	
<article class="abstract xSmall" data-api="/Entries(guid&#39;b20240c2-f3a7-4ee3-a7e3-a72900d416ac&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Web-Audio">Web&#160;Audio</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Web-Audio">
			<img role="img" src="https://sec.ch9.ms/ch9/d60f/810bb450-3b98-4033-ac6b-4f4e53b1d60f/whws2e8WebAudio_512.jpg" alt="Web Audio"/>
			<time class="caption" datetime="00:14:09">14:09</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;19fae751-9968-4037-9485-a72200cb7eca&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Web-Notification-API">Web Notification&#160;API</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Web-Notification-API">
			<img role="img" src="https://sec.ch9.ms/ch9/7de4/655cf461-00ff-4880-89a3-546bc81f7de4/whwS2E8Notificationsv2_512.jpg" alt="Web Notification API"/>
			<time class="caption" datetime="00:14:09">14:09</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;dbed090d-edbe-4594-805e-a71b0113e912&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Using-Azure-Functions-to-Keep-a-Site-Online">Using Azure Functions to Keep a Site&#160;Online</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Using-Azure-Functions-to-Keep-a-Site-Online">
			<img role="img" src="https://sec.ch9.ms/ch9/8540/b1010b27-c7a8-4b5a-a905-a49134128540/whws2e7AlwaysOn_512.jpg" alt="Using Azure Functions to Keep a Site Online"/>
			<time class="caption" datetime="00:09:40">09:40</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;8a5de9f6-6a2b-4885-988a-a71400d9381b&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/LUIS-and-HowHappycouk-mashup">LUIS and HowHappy.co.uk&#160;mashup</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/LUIS-and-HowHappycouk-mashup">
			<img role="img" src="https://sec.ch9.ms/ch9/fb8a/43b4186b-a13b-4fe1-8425-b693c6adfb8a/whwS2E5LuisHowHappy_512.jpg" alt="LUIS and HowHappy.co.uk mashup"/>
			<time class="caption" datetime="00:23:12">23:12</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;a7314845-8d12-4fff-be6b-a70d00c3203b&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Question-and-Answer-Bot">Question and Answer&#160;Bot</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Question-and-Answer-Bot">
			<img role="img" src="https://sec.ch9.ms/ch9/3e23/e2f2540c-0f2b-4192-99eb-f5604e7b3e23/whwS2E4QAMaker_512.jpg" alt="Question and Answer Bot"/>
			<time class="caption" datetime="00:17:51">17:51</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;d0d5716f-cea0-43ad-80a0-a7050113adac&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Creating-404-middleware-in-ASPNET-core">Creating 404 middleware in ASP.NET&#160;core</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Creating-404-middleware-in-ASPNET-core">
			<img role="img" src="https://sec.ch9.ms/ch9/2ffd/25cb0e66-c9fe-4f76-a3de-82de70f82ffd/whwS2E3Middleware_512.jpg" alt="Creating 404 middleware in ASP.NET core"/>
			<time class="caption" datetime="00:13:35">13:35</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;0caa6195-cc05-4720-97c6-a70400dc9df0&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Blogs/StartupIndia">Startup&#160;India</a>
		</div>
		<h3>
			<a href="/Blogs/StartupIndia/Startup-Stories--Meet-Huew">Startup Stories : Meet&#160;Huew</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Blogs/StartupIndia/Startup-Stories--Meet-Huew">
			<img role="img" src="https://sec.ch9.ms/ch9/edab/a52cedf5-a730-4d90-bf53-2cc771dbedab/Huew_512.jpg" alt="Startup Stories : Meet Huew"/>
			<time class="caption" datetime="00:03:29">03:29</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;63a5e6ed-6b13-449d-a7a5-a6f901267f2c&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Web-Hack-Wednesday">Web Hack&#160;Wednesday</a>
		</div>
		<h3>
			<a href="/Shows/Web-Hack-Wednesday/Recommendations-API">Recommendations&#160;API</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Web-Hack-Wednesday/Recommendations-API">
			<img role="img" src="https://sec.ch9.ms/ch9/d614/5471ce3c-1aa1-4dbe-9d87-27060d24d614/whwS2E2Recomendations_512.jpg" alt="Recommendations API"/>
			<time class="caption" datetime="00:17:58">17:58</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;9e85aecf-f5b0-45f4-8606-a6f9017fb344&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/This+Week+On+Channel+9">This Week On Channel&#160;9</a>
		</div>
		<h3>
			<a href="/Shows/This+Week+On+Channel+9/TWC9-Kicking-off-the-year-with-CES-Windows-Holographic-VR-headsets-Windows-Developer-Day-and-more">TWC9: Kicking off the year with CES, Windows Holographic VR headsets, Windows&#160;Developer&#8230;</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/This+Week+On+Channel+9/TWC9-Kicking-off-the-year-with-CES-Windows-Holographic-VR-headsets-Windows-Developer-Day-and-more">
			<img role="img" src="https://sec.ch9.ms/ch9/4204/dee8aff7-0bdd-47b9-9716-b4e0b8c34204/20170113TWC9_512.jpg" alt="TWC9: Kicking off the year with CES, Windows Holographic VR headsets, Windows Developer Day and more..."/>
			<time class="caption" datetime="00:14:07">14:07</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;86d3e66b-9412-4567-95f6-a6e2017462a2&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/Microsoft-Research">Microsoft&#160;Research</a>
		</div>
		<h3>
			<a href="/Shows/Microsoft-Research/A-Practical-Guide-to-Neural-Machine-Translation">A Practical Guide to Neural Machine&#160;Translation</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/Microsoft-Research/A-Practical-Guide-to-Neural-Machine-Translation">
			<img role="img" src="https://sec.ch9.ms/ch9/58dc/a8813253-2fbd-434a-a8b2-d82c179658dc/38468_512.jpg" alt="A Practical Guide to Neural Machine Translation"/>
			<time class="caption" datetime="01:22:47">01:22:47</time>
	</a>
</article>

			</div>
		</div>
	</section>

	<section class="followTheDiscussion">
	
		<div class="container">
			<div class="holder">
				<div class="commentLinks">
				</div>
				<h2>The Discussion</h2>
			
				<ul class="discussion" id="comments">
				</ul>
				
				

						<!-- this form is for not signed in users -->
						<form method="post" id="commentState" class="ch9form discussion episode" autocomplete="off">
							
							<fieldset id="commentForm">
								<h2>Add Your 2 Cents</h2>
								<ul class="clearfix">
									<li>
										<label class="subject" for="CommentState_Subject">Are you human? If so, leave this field blank.</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.Subject" data-valmsg-replace="true"></span>
										<input class="subject" id="CommentState_Subject" name="CommentState.Subject" type="text" value="" />
									</li>
									<li>
										<label for="CommentState_AnonymousUser_DisplayName">Name</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.DisplayName" data-valmsg-replace="true"></span>
										<input data-val="true" data-val-regex="Please enter a name with only letters, numbers, and spaces" data-val-regex-pattern="[A-Za-z0-9][A-Za-z 0-9]+[A-Za-z0-9]" data-val-required="Name field is required" id="CommentState_AnonymousUser_DisplayName" name="CommentState.AnonymousUser.DisplayName" type="text" value="" />
									</li>
									<li>
										<label for="CommentState_AnonymousUser_Email">Email</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.Email" data-valmsg-replace="true"></span>
										<input data-val="true" data-val-email="Please enter your email address in the format someone@example.com" data-val-required="Email address is required" id="CommentState_AnonymousUser_Email" name="CommentState.AnonymousUser.Email" type="text" value="" />
									</li>
									<li class="sign-in">
										<span class="conjunction">Or</span>
										<a class="buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1489689450&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2FShows%2FWeb-Hack-Wednesday%2FCustom-Speech-Service-and-Beezy&amp;id=47159">Sign In</a>
									</li>
									<li>
										<label for="CommentState_AnonymousBody">Comment</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousBody" data-valmsg-replace="true"></span>
										<textarea class="comment" cols="100" data-val="true" data-val-requireone="Comment field is required." data-val-requireone-otherpropertyname="AuthenticatedBody" id="CommentState_AnonymousBody" name="CommentState.AnonymousBody" rows="10">
</textarea>
									</li>
									<li>
										<input name="__RequestVerificationToken" type="hidden" value="DGxC5crdGqSntGV5cLFHnk7UpwZ9AQB6MEQ8VpOPLsXVNsq4D6-5lig10tjs2yaww-qR9wYBBj9WfQ_nTdS14TkGsbk1" />
										<input type="submit" value="Comment" class="buttonPri"/>
									</li>
								</ul>
							</fieldset>
						</form>
			</div>
		</div>
	
	</section>

</main>



<footer role="contentinfo">
	<div class="container">

		<ul class="sharing">
			<li>
				<a href="/ContactUs" class="email mediumIcon"><span class="screenReader">Email</span></a>
			</li>
			<li>
				<a href="https://twitter.com/ch9" class="twitter mediumIcon"><span class="screenReader">Twitter</span></a>
			</li>
			<li>
				<a href="https://www.facebook.com/msftchannel9" class="facebook mediumIcon"><span class="screenReader">Facebook</span></a>
			</li>
			<li>
				<a href="https://s.ch9.ms/Feeds/RSS" class="rss mediumIcon"><span class="screenReader">RSS</span></a>
			</li>
		</ul>

		<ul class="otherLinks">
			<li>
				<a href="/About">About</a>
			</li>
			<li>
				<a href="/Browse/Authors?direction=desc">Authors</a>
			</li>
			<li>
				<a href="/Events/Speakers?direction=desc">Speakers</a>
			</li>
			<li>
				<a href="/Browse/Tags?letter=A">Tags</a>
			</li>
			<li>
				<a href="/ContactUs">Contact Us</a>
			</li>
			<li>
				<a href="/localization/chrome?returnUrl=%252fShows%252fWeb-Hack-Wednesday%252fCustom-Speech-Service-and-Beezy">
					English
				</a>
			</li>
			<li>
				<a href="/CodeOfConduct">Code of Conduct</a>
			</li>
			<li>
				<a href="http://go.microsoft.com/?linkid=4412892">Terms of Service</a>
			</li>
			<li>
				<a href="http://www.microsoft.com/privacystatement/en-us/Channel9App/Default.aspx">Privacy Statement</a>
			</li>
		</ul>

		<p class="copyright">
			&copy; 2017 Microsoft. <wbr>Microsoft reserves all rights associated with the materials on this site.
		</p>
	</div>
</footer>
			
		
		<!-- Host Location: channel9website -->
		<!-- non-realtime scripts. ALL external scripts must be lazy loaded -->
		<!-- Tracking scripts. Social media scripts for facebook, twitter, new relic, web trends -->
			<script src="//tags.tiqcdn.com/utag/msft/ch9/prod/utag.js"></script>
	</body>
</html>