<!DOCTYPE html>
<html class="no-js descriptionEmbedFormat_description" dir="ltr" lang="en">
	<head>

		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
		<title>One Browser Extension Tutorial to Rule... &#124; Coding4Fun Blog &#124; Channel 9</title>
		<meta http-equiv="X-UA-Compatible" content="IE=edge">


		<meta name="viewport" content="width=device-width, initial-scale=1.0">

		<meta name="application-name" content="Channel 9">
		<meta name="msapplication-TileImage" content="/mstile-70x70.png">
		<meta name="msapplication-TileColor" content="#D2730D">
		<meta name="msapplication-config" content="/browserconfig.xml">
		<meta name="msapplication-task" content="name=Coffeehouse;action-uri=/forums/coffeehouse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Browse All Content;action-uri=/Browse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Shows;action-uri=/Browse/Shows;icon-uri=/favicon.ico">
		<meta name="apple-itunes-app" content="app-id=994423736">
		<link rel="manifest" href="/manifest.json">


		<link rel="shortcut icon" type="image/vnd.microsoft.icon" href="/favicon.ico">
		<link rel="apple-touch-icon" href="/favicon-129x129.png">
		

		<link rel="videothumbnail" type="image/jpeg" href="https://f.ch9.ms/thumbnail/50bd019d-9c08-4a3c-9d7b-f36e72e925e8.png"/>
		<link rel="image_src" href="https://f.ch9.ms/thumbnail/50bd019d-9c08-4a3c-9d7b-f36e72e925e8.png"/>
	<link rel="canonical" href="https://channel9.msdn.com/coding4fun/blog/One-Browser-Extension-Tutorial-to-Rule-Them-All"/>
	<link rel="alternate" type="application/rss+xml" href="/coding4fun/blog/One-Browser-Extension-Tutorial-to-Rule-Them-All/RSS" title="One Browser Extension Tutorial to Rule... Feed (Comments) - Channel 9"/>
	<meta name="description" content="In a Web Wednesday post, we&#39;re highlighting a great tutorial from David Rousset. David shows us how we can write one browser extension that works in every modern browser (except Safari). AND he shows "/>
	<meta name="keywords" content="Browser,Coding4Fun,Extensions,google chrome,JavaScript"/>
	<meta name="CommentCount" content="0"/>
	<meta property="og:title" content="One Browser Extension Tutorial to Rule..."/>
	<meta property="og:description" content="In a Web Wednesday post, we&#39;re highlighting a great tutorial from David Rousset. David shows us how we can write one browser extension that works in every modern browser (except Safari). AND he shows "/>
	<meta property="og:type" content="video"/>
	<meta property="og:image" content="https://f.ch9.ms/thumbnail/838e0e72-333e-47b8-aa0d-8511ff3be63b.png"/>
	<meta property="og:image:secure_url" content="https://f.ch9.ms/thumbnail/838e0e72-333e-47b8-aa0d-8511ff3be63b.png"/>
	<meta property="og:url" content="https://channel9.msdn.com/coding4fun/blog/One-Browser-Extension-Tutorial-to-Rule-Them-All"/>
	<meta property="og:site_name" content="Channel 9"/>
	


		<link href="https://s.ch9.ms/c/global.css?v=vPgaDVn85J0plb5-RyCm36rn9OE1InzpVnWJYYD3QbI1" rel="stylesheet" type="text/css"/>
	<link href="https://s.ch9.ms/c/series.css?v=dWM65gr84KaG5I3JmoqGn7bRWv1o_600rXEIHf8PKrA1" rel="stylesheet" type="text/css"/>




		<script>
			var ch9 = ch9 || {data:{},functions:{},value:{}};
			ch9.value.CDNRoot='https://s.ch9.ms/';
		</script>

			<!--[if lt IE 9]>
				<script src="https://s.ch9.ms/j/ie8.js?v=8EwjwTmTL0-jc8hoKqU8RfJ_iLJ6Ss4xiXoSppqiHas1"></script>
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-1.12.0.min.js"></script>
			<![endif]-->
			<!--[if gte IE 9]><!-->
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-3.1.0.min.js"></script>
			<!--<![endif]-->

		<script>
			window.jQuery || document.write('<script src="/js/jquery/jquery-1.12.0.js"><\/script>')
		</script>
<script>
	if(!ch9){
		var ch9={data:{},functions:{},value:{}};
	}
	ch9.value.CDNRoot='https://s.ch9.ms/';
	ch9.value.rnd='-Q7hvPlhz2T73BmAVGqV1e83Lo41';
	ch9.data.culture = "en";
</script>
<!--[if lte IE 8]><script src="https://s.ch9.ms/js/global/iso8601parse.js?v=-Q7hvPlhz2T73BmAVGqV1e83Lo41"></script><![endif]-->


		
		<!--[if lt IE 7]><script>ch9.data.isIE6=true;</script><![endif]-->
		<script src="https://s.ch9.ms/j/global_en.js?v=-Q7hvPlhz2T73BmAVGqV1e83Lo41"></script>
		<script src="/j/strings/Js/en?callback=ch9.functions.Resources.ch9ResourcesCallback" type="text/javascript"></script>
	<script src="https://s.ch9.ms/j/series.js?v=EyrXjUa3tq8qBnGQBiB2hiToxaCO5apc-adYgerq38k1"></script>

	</head>

	<body class="episode hasBanner" dir="ltr" data-guid="06f2c61a-0852-4800-b8dc-a74f0121d47e" lang="en">
			
<header role="banner">
	<a tabindex="0" class="screenReader" href="#mainContent">Skip Navigation</a>
	<div class="navHolder holder">
		<nav class="container" role="navigation" aria-label="Main Navigation">
			<h1 class="screenReader">Primary Navigation</h1>

			<div class="brand">
				<a href="/" class="ch9Logo">
					<span class="ch9Name">Channel 9 Home</span>
				</a>
			</div>

			<button class="navigationToggle buttonTog" aria-pressed="false" aria-label="Toggle main navigation visibility">
				<span class="screenReader">
					Site Navigation
				</span>
			</button>

			<ul role="menubar" class="mainNavigation">
				<li>
					<a role="menuitem" href="/Browse/AllContent">All Content</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/AllShows">Shows</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/Events">Events</a>
				</li>
			</ul>

			<button class="searchToggle buttonTog" aria-pressed="false" aria-label="Toggle search form visibility">
				<span class="screenReader">
					Toggle Search
				</span>
			</button>

			<div class="siteSearch" role="complementary">
				<form class="bypassDirty" autocomplete="off" action="/Search" role="form">
					<label for="siteSearchText" class="screenReader">Search Channel 9</label>
					<input id="siteSearchText" type="text" name="term" placeholder="Search Channel 9" role="search"/>
					<label id="siteSearchButtonLabel" for="siteSearchButton">Search</label>
					<input id="siteSearchButton" type="submit" value="Search"/>
				</form>
			</div>

			<div class="userHolder">
					<a class="signInOut buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1492006636&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fblog%2FOne-Browser-Extension-Tutorial-to-Rule-Them-All&amp;id=47159">Sign In</a>
			</div>
					
		</nav>
	</div>
</header>

<a class="screenReader" id="mainContent"></a>


	

<main role="main">
	<div class="itemHead holder" dir="ltr" lang="en">
		<div class="container">

			<div class="adminLinks">
					<div class="queueHolder">
							<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1492006636&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fblog%2FOne-Browser-Extension-Tutorial-to-Rule-Them-All&amp;id=47159">Sign in to queue</a>
						<div class="queueError holder hidden">
							<div class="container">
								Sorry, an error occurred.
								<button class="close">
									<span class="screenReader">
										Close
									</span>
								</button>
							</div>
						</div>
					</div>
			</div>
			
			<div class="seriesTitle">
					<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
			</div>
			<h1>One Browser Extension Tutorial to&#160;Rule...</h1>
			<ul class="metaData">
				<li class="episode group">
					<div class="releaseDate">
							<time class="timeHelper" data-message="This session is scheduled to begin Apr 12, 2017 at 6:00AM (UTC-07:00).
Based on your computer’s local time settings, this session is scheduled to begin Apr 12, 2017 at 1:00PM (UTC+00:00)." datetime="2017-04-12 13:00:00Z">Apr 12, 2017 at 6:00AM</time>
					</div>
					<div class="authors">
						by <a href="/Niners/gduncan411">Greg Duncan</a>
					</div>
				</li>
				<li class="community group">
					<div class="rating">

<div class="ratingHolder" role="complementary">



		<a href="#" class="averageRating" title="Average of 0 out of 5 stars">
			<span style="width: 0%" itemtype="http://schema.org/AggregateRating" itemprop="aggregateRating">
				<span class="screenReader">
					Average of 0 out of 5 stars
				</span>
			</span>
		</a><span class="count">0</span> ratings

		<div class="signInToRate holder hidden">
			<div class="container">
				<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1492006636&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fblog%2FOne-Browser-Extension-Tutorial-to-Rule-Them-All&amp;id=47159">Sign in to rate</a>
				<button class="close">
					<span class="screenReader">
						Close
					</span>
				</button>
			</div>
		</div>


</div>
					</div>
				</li>
			</ul>
		</div>
	</div>

	<div class="itemBody holder">
		<div class="container">
			



<style>
/* Video player
-------------------------------------------------- */

html.embedded {
	overflow: hidden;
}

html.embedded body.hasVideo {
	height: 100%;
	width: 100%;
}

.playerContainer {
	clear: both;
	font-family: segoe-ui_normal, 'Segoe UI', Segoe, 'Segoe WP', Tahoma, Verdana, Arial, sans-serif;
	height: 100%;
	position: relative;
	width: 100%;
}

.playerContainer a.video {
	background-color: #8f8f8f;
	background-position: center center;
	background-repeat: no-repeat;
	background-size: cover;
	display: block;
	height: 100%;
    position: relative;
	width: 100%;
}

.playerContainer a.video:before {
	content: "";
	display: block;
	padding-top: 56.25%;
}

.playerContainer a.video:active,
.playerContainer a.video:hover {
	text-decoration: none;
}

.playerContainer a.video .caption {
	background-color: rgba(0, 0, 0, .75);
	bottom: 0;
	color: #fff;
	display: block;
	font-size: 1.1rem;
	padding: 2% 4%;
	position: absolute;
}

body[dir=ltr] .playerContainer a.video .caption {
	left: 0;
}

body[dir=rtl] .playerContainer a.video .caption {
	right: 0;
}

.playerContainer > .video > .play {
	background-position: center center;
	background-repeat: no-repeat;
	background-size: cover;
	display: block;
	font-size: 0;
	overflow: hidden;
	padding-top: 56.25%;
	position: absolute;
	text-indent: -9999px;
	top: 0;
	width: 100% !important;
	z-index: 9;
}

.playerContainer > .video > .play:before {
	background-color: rgba(0, 0, 0, .5);
	border: 2px solid rgba(0, 0, 0, .2);
	border-radius: 8px;
	bottom: 0;
	color: transparent;
	content: "";
	cursor: pointer;
	display: inline-block;
	height: 16%;
	left: 0;
	margin: auto;
	position: absolute;
	right: 0;
	text-indent: -9999px;
	top: 0;
	transition: background-color 200ms ease 0s;
	width: 9%;
	z-index: 10;
}

.playerContainer > .video:focus > .play:before {
	outline: 2px solid #004e8e;
}

.playerContainer > .video > .play:after {
	background-image: url('data:image/png;base64,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');
}

.playerContainer > .video > .play:after {
	background-position: right center;
	background-repeat: no-repeat;
	bottom: 0;
	content: "";
	display: inline-block;
	left: 1.3%;
	position: absolute;
	right: 0;
	top: 0;
	width: 4.5%;
	height: 16.215%;
	margin: auto;
	z-index: 11;
}

.playerContainer.noVideo > .video > .play:before,
.playerContainer.noVideo > .video > .play:after {
	display: none;
}

.playerContainer > .video > .play:hover:before {
	background-color: rgba(0, 0, 0, 0.9);
	color: transparent;
}

.playerContainer .progress.circles {
	background-color: transparent;
	border: none;
}

.playerContainer .playerGoesHere {
	background-color: #fff;
	display: none;
	height: 100%;
	width: 100%;
}

.playerContainer video.Player {
	height: 100%;
	width: 100%;
}

.playerContainer .playerGoesHere.fullscreen {
	height: 100%;
	left: 0;
	overflow: hidden;
	position: fixed;
	top: 0;
	width: 100%;
	z-index: 9999;
}

.playerContainer ul.mediaformat,
.playerContainer ul.mediacaptions {
	display: none;
}

.playerContainer .playerGoesHere .error {
	background-color: #464646;
	color: #fff;
	padding: 40px;
	vertical-align: middle;
}

.playerContainer .playerGoesHere .error a,
.playerContainer .playerGoesHere .error a:hover,
.playerContainer .playerGoesHere .error a:focus {
	color: #ffb20b;
}

.playerContainer .error h3 {
	font-size: 120%;
	margin-top: 1.13rem;
}
</style>
<style>
	body {
		margin: 0;
		padding: 0;
	}
</style>



			<div class="download">

			</div>

			<div class="ch9tabGroup descriptionEmbedFormat" data-ch9tab_group_name="descriptionEmbedFormat" role="tablist">
				<section class="ch9tab description" data-ch9tab_name="description">
					<h2 role="tab" tabindex="0">Description</h2>
					<div class="ch9tabContent" dir="ltr" lang="en" role="tabpanel">
						<p>In a Web Wednesday post, we're highlighting a great tutorial from David Rousset.</p><p>David shows us how we can write one browser extension that works in every modern browser (except Safari).</p><p>AND he shows how you can use that extension to connect to a number of Microsoft services, such as the Microsoft Cognitive Services Computer Vision API and Bing Text to Speech API too.</p><p>Finally, while using shared code, how to also add browser specific features too.</p><h2><a href="https://www.smashingmagazine.com/2017/04/browser-extension-edge-chrome-firefox-opera-brave-vivaldi/">Creating One Browser Extension For All Browsers: Edge, Chrome, Firefox, Opera, Brave And Vivaldi</a></h2><blockquote><p>&quot;In today’s article, we’ll create a JavaScript extension that works in all major modern browsers, using the very same code base. Indeed, the Chrome extension model based on HTML, CSS and JavaScript is now available almost everywhere, and there is even a <a href="https://browserext.github.io/">Browser Extension Community Group</a> working on a standard.</p><p>I’ll explain how you can install this extension that supports the web extension model (I.e. Edge, Chrome, Firefox, Opera, Brave and Vivaldi), and provide some simple tips on how to get a unique code base for all of them, but also how to debug in each browser.</p><p>...</p><h5>Our Extension <a href="https://www.smashingmagazine.com/2017/04/browser-extension-edge-chrome-firefox-opera-brave-vivaldi/#our-extension">Link</a></h5><p>Let’s build a proof of concept — an extension that uses artificial intelligence (AI) and computer vision to help the blind analyze images on a web page.</p><p>We’ll see that, with a few lines of code, we can create some powerful features in the browser. In my case, I’m concerned with <strong>accessibility on the web</strong> and I’ve already spent some time thinking about how to make a <a href="https://www.davrous.com/2015/08/27/creating-an-accessible-breakout-game-using-web-audio-svg/">breakout game accessible using web audio and SVG</a>, for instance.</p><p>Still, I’ve been looking for something that would <strong>help blind people</strong> in a more general way. I was recently inspired while listening to a great talk by <a href="https://twitter.com/codepo8">Chris Heilmann</a> in Lisbon: “<a href="https://www.youtube.com/watch?v=TWVNTsdm27U">Pixels and Hidden Meaning in Pixels</a>.”</p><p>Indeed, using today’s AI algorithms in the cloud, as well as text-to-speech technologies, exposed in the browser with the <a href="https://dvcs.w3.org/hg/speech-api/raw-file/tip/speechapi.html#tts-section">Web Speech API</a> or using a remote cloud service, we can very easily build an extension that analyzes web page images with missing or improperly filled <code>alt</code> text properties.</p><p>My little proof of concept simply extracts images from a web page (the one in the active tab) and displays the thumbnails in a list. When you click on one of the images, the extension queries the <strong>Computer Vision API</strong> to get some descriptive text for the image and then uses either the <strong>Web Speech API</strong> or <strong>Bing Speech API</strong> to share it with the visitor.</p><p>...</p><p><a href="https://f.ch9.ms/wlwimages/ae054c0b4d7b402ab1239e6800c0220f/image[3]-172.png"><img title="image" src="https://f.ch9.ms/wlwimages/ae054c0b4d7b402ab1239e6800c0220f/image_thumb[1]-238.png" alt="image" width="586" height="331" border="0"></a></p><p>...&quot; [<a href="https://www.smashingmagazine.com/2017/04/browser-extension-edge-chrome-firefox-opera-brave-vivaldi/">Click through to read and follow the entire tutorial</a>]</p></blockquote><p><a class="twitter-follow-button" href="https://twitter.com/ch9">Follow @CH9</a> <br><a class="twitter-follow-button" href="https://twitter.com/coding4fun">Follow @coding4fun</a> <br><a class="twitter-follow-button" href="https://twitter.com/gduncan411">Follow @gduncan411</a></p>

						<div class="details" dir="ltr" lang="en">
							<div class="tags">
								<h3>Tags:</h3>
								<a href="/Tags/browser">Browser</a><span>, </span><a href="/Tags/coding4fun">Coding4Fun</a><span>, </span><a href="/Tags/extensions">Extensions</a><span>, </span><a href="/Tags/google+chrome">google chrome</a><span>, </span><a href="/Tags/javascript">JavaScript</a>
							</div>
						</div>
					</div>
				</section>



			</div>
		</div>
	</div>

	<section class="moreEpisodes">
		<div class="container">
			<div class="holder">
					<h2>More episodes in this series</h2>
					

	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;d32282c8-a50c-4860-ae6b-a74801229914&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/C64ForTheWin-C64-Development-on-your-Windows-Machine">C64ForTheWin - C64 Development on your Windows&#160;Machine</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/C64ForTheWin-C64-Development-on-your-Windows-Machine">
			<img role="img" src="https://f.ch9.ms/thumbnail/e4f9ce62-a76d-4f9a-a02f-953a65d4767f.png" alt="C64ForTheWin - C64 Development on your Windows Machine"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;8f732716-b6b9-411c-9e2d-a74f011dec62&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Squish-That-Whitespace">Squish That&#160;Whitespace</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Squish-That-Whitespace">
			<img role="img" src="https://f.ch9.ms/thumbnail/a878da3a-8fa3-4332-96ac-c00f8b5639ae.jpg" alt="Squish That Whitespace"/>
	</a>
</article>

					<h2>Related episodes</h2>
					

	
<article class="abstract xSmall" data-api="/Entries(guid&#39;cf426278-154b-42a6-89c6-a74e01042810&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Shows/This+Week+On+Channel+9">This Week On Channel&#160;9</a>
		</div>
		<h3>
			<a href="/Shows/This+Week+On+Channel+9/TWC9-400-SpringIntoDevOps-Windows-10-1703--SDK-Out-Project-Scorpio-Revealed-and-more">TWC9: 400! #SpringIntoDevOps, Windows 10 1703 & SDK Out, Project Scorpio Revealed&#160;and&#8230;</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Shows/This+Week+On+Channel+9/TWC9-400-SpringIntoDevOps-Windows-10-1703--SDK-Out-Project-Scorpio-Revealed-and-more">
			<img role="img" src="https://sec.ch9.ms/ch9/860d/f2051ec8-bfb8-4abe-948a-a9dc0481860d/TWC9Episode400_512.jpg" alt="TWC9: 400! #SpringIntoDevOps, Windows 10 1703 &amp; SDK Out, Project Scorpio Revealed and more..."/>
			<time class="caption" datetime="00:22:49">22:49</time>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;32729b3e-ce04-40f5-a745-a702012761e2&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Babylonjs-v25">Babylon.js&#160;v2.5</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Babylonjs-v25">
			<img role="img" src="https://f.ch9.ms/thumbnail/8caf77aa-e884-4096-9126-a46107829255.png" alt="Babylon.js v2.5"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;99d82cc0-bbbf-45aa-bd59-a6d1017e15f9&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Get-19-VS-2017-Web-Extensions-with-Just-One-Install">Get 19 VS 2017 Web Extensions with Just One&#160;Install</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Get-19-VS-2017-Web-Extensions-with-Just-One-Install">
			<img role="img" src="https://f.ch9.ms/thumbnail/9209dbe8-b17f-4c69-a599-d941f0ad4d46.png" alt="Get 19 VS 2017 Web Extensions with Just One Install"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;d3f8776d-7927-417e-80cb-a6bc0144ca52&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Guarding-the-code-with-Package-Security-Alerts-and-Roslyn-Security-Guard">Guarding the code with Package Security Alerts and Roslyn Security&#160;Guard</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Guarding-the-code-with-Package-Security-Alerts-and-Roslyn-Security-Guard">
			<img role="img" src="https://f.ch9.ms/thumbnail/c5a475b3-ca5b-470b-8d62-95a31b6f1540.png" alt="Guarding the code with Package Security Alerts and Roslyn Security Guard"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;572626b7-a630-4d93-a5d3-a699015728e8&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Blockly-Windows-10-IoT">Blockly Windows 10&#160;IoT</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Blockly-Windows-10-IoT">
			<img role="img" src="https://f.ch9.ms/thumbnail/b8f2e71c-a10b-46b1-aa23-0820a186b089.png" alt="Blockly Windows 10 IoT"/>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;614e9aa1-5ecb-4f9f-aa2e-a67a01325e30&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Blogs/One-Dev-Minute">One Dev&#160;Minute</a>
		</div>
		<h3>
			<a href="/Blogs/One-Dev-Minute/Maps-and-Sets-in-JavaScript-ES2015">Maps and Sets in JavaScript&#160;ES2015</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Blogs/One-Dev-Minute/Maps-and-Sets-in-JavaScript-ES2015">
			<img role="img" src="https://sec.ch9.ms/ch9/ba9e/a4a53b0a-c01e-4ced-85cb-e9c09ce3ba9e/MapsAndSets_512.jpg" alt="Maps and Sets in JavaScript ES2015"/>
			<time class="caption" datetime="00:01:46">01:46</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;9b13c950-fabb-4fef-90cd-a66d0127864e&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Blogs/msedgedev">The Microsoft Edge Dev&#160;Show</a>
		</div>
		<h3>
			<a href="/Blogs/msedgedev/Edge-14-overview">What's new in Edge&#160;14</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Blogs/msedgedev/Edge-14-overview">
			<img role="img" src="https://sec.ch9.ms/ch9/b329/559509e1-8f4f-4ede-873c-488a022db329/Edge14_512.jpg" alt="What&#39;s new in Edge 14"/>
			<time class="caption" datetime="00:15:19">15:19</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;60913724-daac-4c23-bc69-a659016299d0&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Blogs/One-Dev-Minute">One Dev&#160;Minute</a>
		</div>
		<h3>
			<a href="/Blogs/One-Dev-Minute/Rest-Parameters-and-Spread-Operators-in-JavaScript-ES2015">Rest Parameters and Spread Operators in JavaScript&#160;ES2015</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Blogs/One-Dev-Minute/Rest-Parameters-and-Spread-Operators-in-JavaScript-ES2015">
			<img role="img" src="https://sec.ch9.ms/ch9/e43d/2a6b037c-ea38-4d8a-ab88-685637d1e43d/RestParameters_512.jpg" alt="Rest Parameters and Spread Operators in JavaScript ES2015"/>
			<time class="caption" datetime="00:01:20">01:20</time>
	</a>
</article>


	
<article class="abstract xSmall" data-api="/Entries(guid&#39;e8670f06-729d-4191-9cde-a6490185d2ef&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/Blogs/One-Dev-Minute">One Dev&#160;Minute</a>
		</div>
		<h3>
			<a href="/Blogs/One-Dev-Minute/Default-parameters-in-JavaScript-ES2015">Default parameters in JavaScript&#160;ES2015</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/Blogs/One-Dev-Minute/Default-parameters-in-JavaScript-ES2015">
			<img role="img" src="https://sec.ch9.ms/ch9/9b48/23439980-a7aa-4672-a906-9b4a11f79b48/DefaultParameters_512.jpg" alt="Default parameters in JavaScript ES2015"/>
			<time class="caption" datetime="00:01:58">01:58</time>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;8a1fc891-33a1-4b35-9b5f-a64501626d07&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/Being-Cross-with-WebGL-and-Babylonjs">Being Cross with WebGL and&#160;Babylon.js</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/Being-Cross-with-WebGL-and-Babylonjs">
			<img role="img" src="https://f.ch9.ms/thumbnail/530f0996-4234-4e74-bfb9-730c84d0a826.png" alt="Being Cross with WebGL and Babylon.js"/>
	</a>
</article>

			</div>
		</div>
	</section>

	<section class="followTheDiscussion">
	
		<div class="container">
			<div class="holder">
				<div class="commentLinks">
				</div>
				<h2>The Discussion</h2>
			
				<ul class="discussion" id="comments">
				</ul>
				
				

						<!-- this form is for not signed in users -->
						<form method="post" id="commentState" class="ch9form discussion episode" autocomplete="off">
							
							<fieldset id="commentForm">
								<h2>Add Your 2 Cents</h2>
								<ul class="clearfix">
									<li>
										<label class="subject" for="CommentState_Subject">Are you human? If so, leave this field blank.</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.Subject" data-valmsg-replace="true"></span>
										<input class="subject" id="CommentState_Subject" name="CommentState.Subject" type="text" value="" />
									</li>
									<li>
										<label for="CommentState_AnonymousUser_DisplayName">Name</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.DisplayName" data-valmsg-replace="true"></span>
										<input data-val="true" data-val-regex="Please enter a name with only letters, numbers, and spaces" data-val-regex-pattern="[A-Za-z0-9][A-Za-z 0-9]+[A-Za-z0-9]" data-val-required="Name field is required" id="CommentState_AnonymousUser_DisplayName" name="CommentState.AnonymousUser.DisplayName" type="text" value="" />
									</li>
									<li>
										<label for="CommentState_AnonymousUser_Email">Email</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.Email" data-valmsg-replace="true"></span>
										<input data-val="true" data-val-email="Please enter your email address in the format someone@example.com" data-val-required="Email address is required" id="CommentState_AnonymousUser_Email" name="CommentState.AnonymousUser.Email" type="text" value="" />
									</li>
									<li class="sign-in">
										<span class="conjunction">Or</span>
										<a class="buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1492006636&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fblog%2FOne-Browser-Extension-Tutorial-to-Rule-Them-All&amp;id=47159">Sign In</a>
									</li>
									<li>
										<label for="CommentState_AnonymousBody">Comment</label>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousBody" data-valmsg-replace="true"></span>
										<textarea class="comment" cols="100" data-val="true" data-val-requireone="Comment field is required." data-val-requireone-otherpropertyname="AuthenticatedBody" id="CommentState_AnonymousBody" name="CommentState.AnonymousBody" rows="10">
</textarea>
									</li>
									<li>
										<input name="__RequestVerificationToken" type="hidden" value="DKOVigSrQVzWSst5wzngyYRWiUfhjRgSsD-292m5lj1iIbVxOB-ym_Fcaa1GVq5xCZCs5OSsxn70QAPtD_looXsw4-I1" />
										<input type="submit" value="Comment" class="buttonPri"/>
									</li>
								</ul>
							</fieldset>
						</form>
			</div>
		</div>
	
	</section>

</main>



<footer role="contentinfo">
	<div class="container">

		<ul class="sharing">
			<li>
				<a href="/ContactUs" class="email mediumIcon"><span class="screenReader">Email</span></a>
			</li>
			<li>
				<a href="https://twitter.com/ch9" class="twitter mediumIcon"><span class="screenReader">Twitter</span></a>
			</li>
			<li>
				<a href="https://www.facebook.com/msftchannel9" class="facebook mediumIcon"><span class="screenReader">Facebook</span></a>
			</li>
			<li>
				<a href="https://s.ch9.ms/Feeds/RSS" class="rss mediumIcon"><span class="screenReader">RSS</span></a>
			</li>
			<li>
				<a href="https://www.reddit.com/r/ch9" class="reddit mediumIcon">
					<span class="screenReader">RSS</span>
				</a>
			</li>
		</ul>

		<ul class="otherLinks">
			<li>
				<a href="/About">About</a>
			</li>
			<li>
				<a href="/Browse/Authors?direction=desc">Authors</a>
			</li>
			<li>
				<a href="/Events/Speakers?direction=desc">Speakers</a>
			</li>
			<li>
				<a href="/Browse/Tags?letter=A">Tags</a>
			</li>
			<li>
				<a href="/ContactUs">Contact Us</a>
			</li>
			<li>
				<a href="/localization/chrome?returnUrl=%252fcoding4fun%252fblog%252fOne-Browser-Extension-Tutorial-to-Rule-Them-All">
					English
				</a>
			</li>
			<li>
				<a href="/CodeOfConduct">Code of Conduct</a>
			</li>
			<li>
				<a href="http://go.microsoft.com/?linkid=4412892">Terms of Service</a>
			</li>
			<li>
				<a href="http://www.microsoft.com/privacystatement/en-us/Channel9App/Default.aspx">Privacy Statement</a>
			</li>
		</ul>

		<p class="copyright">
			&copy; 2017 Microsoft. <wbr>Microsoft reserves all rights associated with the materials on this site.
		</p>
	</div>
</footer>
			
		
		<!-- Host Location: channel9website -->
		<!-- non-realtime scripts. ALL external scripts must be lazy loaded -->
		<!-- Tracking scripts. Social media scripts for facebook, twitter, new relic, web trends -->
			<script src="//tags.tiqcdn.com/utag/msft/ch9/prod/utag.js"></script>
	</body>
</html>