<!DOCTYPE html>
<html class="no-js descriptionEmbedFormat_description" dir="ltr" lang="en">
	<head>

		<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
		<title>Floating HoloLens Screen &#124; Coding4Fun Kinect Projects &#124; Channel 9</title>
		<meta http-equiv="X-UA-Compatible" content="IE=edge">


		<meta name="viewport" content="width=device-width, initial-scale=1.0">

		<meta name="application-name" content="Channel 9">
		<meta name="msapplication-TileImage" content="/mstile-70x70.png">
		<meta name="msapplication-TileColor" content="#D2730D">
		<meta name="msapplication-config" content="/browserconfig.xml">
		<meta name="msapplication-task" content="name=Coffeehouse;action-uri=/forums/coffeehouse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Browse All Content;action-uri=/Browse;icon-uri=/favicon.ico">
		<meta name="msapplication-task" content="name=Shows;action-uri=/Browse/Shows;icon-uri=/favicon.ico">
		<meta name="apple-itunes-app" content="app-id=994423736">
		<link rel="manifest" href="/manifest.json">


		<link rel="shortcut icon" type="image/vnd.microsoft.icon" href="/favicon.ico">
		<link rel="apple-touch-icon" href="/favicon-129x129.png">
		

		<link rel="videothumbnail" type="image/jpeg" href="https://f.ch9.ms/thumbnail/74dc34dc-0d6a-48eb-989f-4c620886a149.png"/>
		<link rel="image_src" href="https://f.ch9.ms/thumbnail/74dc34dc-0d6a-48eb-989f-4c620886a149.png"/>
	<link rel="canonical" href="https://channel9.msdn.com/coding4fun/kinect/Floating-HoloLens-Screen"/>
	<link rel="alternate" type="application/rss+xml" href="/coding4fun/kinect/Floating-HoloLens-Screen/RSS" title="Floating HoloLens Screen Feed (Comments) - Channel 9"/>
	<meta name="description" content="Joost van Schaik is back again, today with cool HoloLens example app... Building a floating HoloLens &#39;info screen&#39; - 1Those who have seen my HoloLens apps (most notably Walk the World) have noticed I "/>
	<meta name="keywords" content="Coding4Fun,Hololens"/>
	<meta name="CommentCount" content="0"/>
	<meta property="og:title" content="Floating HoloLens Screen"/>
	<meta property="og:description" content="Joost van Schaik is back again, today with cool HoloLens example app... Building a floating HoloLens &#39;info screen&#39; - 1Those who have seen my HoloLens apps (most notably Walk the World) have noticed I "/>
	<meta property="og:type" content="video"/>
	<meta property="og:image" content="https://f.ch9.ms/thumbnail/aaca17e5-43a3-4f88-ad35-bbb34359987a.png"/>
	<meta property="og:image:secure_url" content="https://f.ch9.ms/thumbnail/aaca17e5-43a3-4f88-ad35-bbb34359987a.png"/>
	<meta property="og:url" content="https://channel9.msdn.com/coding4fun/kinect/Floating-HoloLens-Screen"/>
	<meta property="og:site_name" content="Channel 9"/>
	


		<link href="https://s.ch9.ms/c/global.css?v=LQFdkgWnbyAdK9XChHXSAgkuTL3xMpH7OcJXNKv1uX01" rel="stylesheet" type="text/css"/>
	<link href="https://s.ch9.ms/c/series.css?v=q6W2KQys8u2i57dsufSLBh_SGF8KGJ1-jMbbb4deaug1" rel="stylesheet" type="text/css"/>




		<script>
			var ch9 = ch9 || {data:{},functions:{},value:{}};
			ch9.value.CDNRoot='https://s.ch9.ms/';
		</script>

			<!--[if lt IE 9]>
				<script src="https://s.ch9.ms/j/ie8.js?v=8EwjwTmTL0-jc8hoKqU8RfJ_iLJ6Ss4xiXoSppqiHas1"></script>
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-1.12.0.min.js"></script>
			<![endif]-->
			<!--[if gte IE 9]><!-->
				<script src="https://ajax.aspnetcdn.com/ajax/jquery/jquery-3.1.0.min.js"></script>
			<!--<![endif]-->

		<script>
			window.jQuery || document.write('<script src="/js/jquery/jquery-1.12.0.js"><\/script>')
		</script>
<script>
	if(!ch9){
		var ch9={data:{},functions:{},value:{}};
	}
	ch9.value.CDNRoot='https://s.ch9.ms/';
	ch9.value.rnd='-Q7hvPlhz2T73BmAVGqV1e83Lo41';
	ch9.data.culture = "en";
</script>
<!--[if lte IE 8]><script src="https://s.ch9.ms/js/global/iso8601parse.js?v=-Q7hvPlhz2T73BmAVGqV1e83Lo41"></script><![endif]-->


		
		<!--[if lt IE 7]><script>ch9.data.isIE6=true;</script><![endif]-->
		<script src="https://s.ch9.ms/j/global_en.js?v=-Q7hvPlhz2T73BmAVGqV1e83Lo41"></script>
		<script src="/j/strings/Js/en?callback=ch9.functions.Resources.ch9ResourcesCallback" type="text/javascript"></script>
	<script src="https://s.ch9.ms/j/series.js?v=qyBWdqahFVGdAnG8DURwxaHTN1N7bG98wqYzlweP7-A1"></script>

	</head>

	<body class="episode hasBanner" dir="ltr" data-guid="af4c69a3-1a7f-441f-8463-a7a301158189" lang="en">
			
<header role="banner">
	<a tabindex="0" class="screenReader" href="#mainContent">Skip Navigation</a>
	<div class="navHolder holder">
		<nav class="container" role="navigation" aria-label="Main Navigation">
			<h1 class="screenReader">Primary Navigation</h1>

			<div class="brand">
				<a href="/" class="ch9Logo">
					<span class="ch9Name">Channel 9 Home</span>
				</a>
			</div>

			<button class="navigationToggle buttonTog" aria-pressed="false" aria-label="Toggle main navigation visibility">
				<span class="screenReader">
					Site Navigation
				</span>
			</button>

			<ul role="menubar" class="mainNavigation">
				<li>
					<a role="menuitem" href="/Browse/AllContent">All Content</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/AllShows">Shows</a>
				</li>
				<li>
					<a role="menuitem" href="/Browse/Events">Events</a>
				</li>
			</ul>

			<button class="searchToggle buttonTog" aria-pressed="false" aria-label="Toggle search form visibility">
				<span class="screenReader">
					Toggle Search
				</span>
			</button>

			<div class="siteSearch" role="complementary">
				<form class="bypassDirty" autocomplete="off" action="/Search" role="form">
					<label for="siteSearchText" class="screenReader">Search Channel 9</label>
					<input id="siteSearchText" type="text" name="term" placeholder="Search Channel 9" role="search"/>
					<label id="siteSearchButtonLabel" for="siteSearchButton">Search</label>
					<input id="siteSearchButton" type="submit" value="Search"/>
				</form>
			</div>

			<div class="userHolder">
					<a class="signInOut buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1499346733&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fkinect%2FFloating-HoloLens-Screen&amp;id=47159">Sign In</a>
			</div>
					
		</nav>
	</div>
</header>

<a class="screenReader" id="mainContent"></a>


	

<main role="main">
	<div class="itemHead holder" dir="ltr" lang="en">
		<div class="container">

			<div class="adminLinks">
				
<div role="complementary" class="subscribeHolder">
		<a class="buttonSub signIn" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1499346733&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fkinect%2FFloating-HoloLens-Screen&amp;id=47159">Sign in to subscribe</a>
	<div class="subscribeError holder hidden">
		<div class="container">
			An error occurred
			<button class="close">
				<span class="screenReader">
					Close
				</span>
			</button>
		</div>
	</div>
</div>
			</div>
			
			<div class="seriesTitle">
					<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
			</div>
			<h1>Floating HoloLens&#160;Screen</h1>
			<ul class="metaData">
				<li class="episode group">
					<div class="releaseDate">
							<time class="timeHelper" data-message="This session is scheduled to begin Jul 06, 2017 at 6:00AM (UTC-07:00).
Based on your computer’s local time settings, this session is scheduled to begin Jul 06, 2017 at 1:00PM (UTC+00:00)." datetime="2017-07-06 13:00:00Z">Jul 06, 2017 at 6:00AM</time>
					</div>
					<div class="authors">
						by <a href="/Niners/gduncan411">Greg Duncan</a>
					</div>
				</li>
				<li class="community group">
					<div class="rating">

<div class="ratingHolder" role="complementary">



		<a href="#" class="averageRating" title="Average of 0 out of 5 stars">
			<span style="width: 0%" itemtype="http://schema.org/AggregateRating" itemprop="aggregateRating">
				<span class="screenReader">
					Average of 0 out of 5 stars
				</span>
			</span>
		</a><span class="count">0</span> ratings

		<div class="signInToRate holder hidden">
			<div class="container">
				<a class="buttonSec" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1499346733&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fkinect%2FFloating-HoloLens-Screen&amp;id=47159">Sign in to rate</a>
				<button class="close">
					<span class="screenReader">
						Close
					</span>
				</button>
			</div>
		</div>


</div>
					</div>
				</li>
			</ul>
		</div>
	</div>

	<div class="itemBody holder">
		<div class="container">
			



<style>
/* Video player
-------------------------------------------------- */

html.embedded {
	overflow: hidden;
}

html.embedded body.hasVideo {
	height: 100%;
	width: 100%;
}

.playerContainer {
	clear: both;
	font-family: segoe-ui_normal, 'Segoe UI', Segoe, 'Segoe WP', Tahoma, Verdana, Arial, sans-serif;
	height: 100%;
	position: relative;
	width: 100%;
}

.playerContainer a.video {
	background-color: #000;
	background-position: center center;
	background-repeat: no-repeat;
	background-size: contain;
	display: block;
	height: 100%;
    position: relative;
	width: 100%;
}

.playerContainer a.video:before {
	content: "";
	display: block;
	padding-top: 56.25%;
}

.playerContainer a.video:active,
.playerContainer a.video:hover {
	text-decoration: none;
}

.playerContainer a.video .caption {
	background-color: rgba(0, 0, 0, .75);
	bottom: 0;
	color: #fff;
	display: block;
	font-size: 1.1rem;
	padding: 2% 4%;
	position: absolute;
}

body[dir=ltr] .playerContainer a.video .caption {
	left: 0;
}

body[dir=rtl] .playerContainer a.video .caption {
	right: 0;
}

.playerContainer > .video > .play {
	display: block;
	font-size: 0;
	overflow: hidden;
	padding-top: 56.25%;
	position: absolute;
	text-indent: -9999px;
	top: 0;
	width: 100% !important;
	z-index: 9;
}

.playerContainer > .video > .play:before {
	background-color: rgba(0, 0, 0, .5);
	border: 2px solid rgba(0, 0, 0, .2);
	border-radius: 8px;
	bottom: 0;
	color: transparent;
	content: "";
	cursor: pointer;
	display: inline-block;
	height: 16%;
	left: 0;
	margin: auto;
	position: absolute;
	right: 0;
	text-indent: -9999px;
	top: 0;
	transition: background-color 200ms ease 0s;
	width: 9%;
	z-index: 10;
}

.playerContainer > .video:focus > .play:before {
	outline: 2px solid #004e8e;
}

.playerContainer > .video > .play:after {
	background-image: url('data:image/png;base64,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');
}

.playerContainer > .video > .play:after {
	background-position: right center;
	background-repeat: no-repeat;
	bottom: 0;
	content: "";
	display: inline-block;
	left: 1.3%;
	position: absolute;
	right: 0;
	top: 0;
	width: 4.5%;
	height: 16.215%;
	margin: auto;
	z-index: 11;
}

.playerContainer.noVideo > .video > .play:before,
.playerContainer.noVideo > .video > .play:after {
	display: none;
}

.playerContainer > .video > .play:hover:before {
	background-color: rgba(0, 0, 0, 0.9);
	color: transparent;
}

.playerContainer .progress.circles {
	background-color: transparent;
	border: none;
}

.playerContainer .playerGoesHere {
	background-color: #000;
	display: none;
	height: 100%;
	width: 100%;
}

.playerContainer video.Player {
	height: 100%;
	width: 100%;
}

.playerContainer .playerGoesHere.fullscreen {
	height: 100%;
	left: 0;
	overflow: hidden;
	position: fixed;
	top: 0;
	width: 100%;
	z-index: 9999;
}

.playerContainer ul.mediaformat,
.playerContainer ul.mediacaptions {
	display: none;
}

.playerContainer .playerGoesHere .error {
	background-color: #464646;
	color: #fff;
	padding: 40px;
	vertical-align: middle;
}

.playerContainer .playerGoesHere .error a,
.playerContainer .playerGoesHere .error a:hover,
.playerContainer .playerGoesHere .error a:focus {
	color: #ffb20b;
}

.playerContainer .error h3 {
	font-size: 120%;
	margin-top: 1.13rem;
}
</style>
<style>
	body {
		margin: 0;
		padding: 0;
	}
</style>


			
			<div class="queueHolder">
					<a class="buttonSub" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1499346733&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fkinect%2FFloating-HoloLens-Screen&amp;id=47159">Sign in to queue</a>
				<div class="queueError holder hidden">
					<div class="container">
						Sorry, an error occurred.
						<button class="close">
							<span class="screenReader">
								Close
							</span>
						</button>
					</div>
				</div>
			</div>

			<div class="ch9tabGroup descriptionEmbedFormat" data-ch9tab_group_name="descriptionEmbedFormat" role="tablist">
				<section class="ch9tab description" data-ch9tab_name="description">
					<h2 role="tab" tabindex="0">Description</h2>
					<div class="ch9tabContent" dir="ltr" lang="en" role="tabpanel">
						<p>Joost van Schaik is back again, today with cool HoloLens example app...</p><h2><a href="http://dotnetbyexample.blogspot.com/2017/06/building-floating-hololens-info-screen-1.html">Building a floating HoloLens 'info screen' - 1</a></h2><blockquote><p>Those who have seen my HoloLens apps (most notably <a href="https://www.microsoft.com/store/productid/9P6SVQQCP2SQ">Walk the World</a>) have noticed I tend to use floating &quot;info screens&quot;, especially for help screens. My apps are mostly voice command driven as I don't like to have floating controls that are in view all of the time. They stress the fact that you are in an virtual environment, and that degrades the actual immersive experience, IMHO. So I go as much for gestures and voice as possible.</p><p>But where there are no visual clues for functionality, there's also lack of discoverability. So I tend to include a voice command &quot;help&quot; or &quot;show help&quot; that brings up a simple floating screen that shows what the app can do.</p><p>A few important things that you might not see right away:</p><ul><li>The screen follows your gaze</li><li>The screen tries to move away from you to be readable, but will stop moving if it get's pushed against an obstacle. So it won't disappear into another hologram or a physical object, like the wall or a floor. Or at least it tries to. I must admit it does not always works perfectly.</li><li>Notice that at first it will appears like 1 meter before you and move into view, next time it will appears where you last left it and then move into view.</li></ul><p>In a two-part post I will describe how I have created such a screen.</p><ul><li>The first part will handle building the actual visual structure in Unity (and one little behavior)</li><li>The second part describes the code for all other Unity behaviors.</li></ul><p>I am going to assume you know a bit about Unity but not too much, so there's going to be lot of images.</p><h4>Setting up a base project ...</h4><p>The basic setup of an info screen ...</p><p>Background plane ...</p><p>Setting some color and reflection ...</p><p>Changing the collider ...</p><p>Adding text ...</p><p>Building the button ...</p><p>A little code for dessert...</p><h4>Conclusion</h4><p>We have built the visual parts of a help screen but with very little functionality or interaction. It's actually not hard to do, if you know what you are doing. I hope I have helped you getting a bit more feeling for that.</p><p>In the next installment, which will hardly contain images, we will see WAY more code.</p><p>The project so far can be <a href="https://github.com/LocalJoost/FloatingScreenDemo/tree/blog1">found at GitHub</a>, as always.</p></blockquote><p><strong>Project Information URL:</strong> <a title="http://dotnetbyexample.blogspot.com/2017/06/building-floating-hololens-info-screen-1.html" href="http://dotnetbyexample.blogspot.com/2017/06/building-floating-hololens-info-screen-1.html">http://dotnetbyexample.blogspot.com/2017/06/building-floating-hololens-info-screen-1.html</a></p><p><strong>Project Download URL:</strong> <a title="https://github.com/LocalJoost/FloatingScreenDemo/tree/blog1" href="https://github.com/LocalJoost/FloatingScreenDemo/tree/blog1">https://github.com/LocalJoost/FloatingScreenDemo/tree/blog1</a></p><p>Contact Information:</p><ul><li>Blog: <a title="http://dotnetbyexample.blogspot.com" href="http://dotnetbyexample.blogspot.com">http://dotnetbyexample.blogspot.com</a></li><li><a class="twitter-follow-button" href="https://twitter.com/localjoost">Follow @localjoost</a></li></ul><p><a class="twitter-follow-button" href="https://twitter.com/ch9">Follow @CH9</a><br><a class="twitter-follow-button" href="https://twitter.com/coding4fun">Follow @Coding4Fun</a><br><a class="twitter-follow-button" href="https://twitter.com/gduncan411">Follow @gduncan411</a></p>

						<div class="details" dir="ltr" lang="en">
							<div class="tags">
								<h3>Tags:</h3>
								<a href="/Tags/coding4fun">Coding4Fun</a><span>, </span><a href="/Tags/hololens">Hololens</a>
							</div>
						</div>
					</div>
				</section>



			</div>
		</div>
	</div>

	<section class="moreEpisodes">
		<div class="container">
			<div class="holder">
					<h2>More episodes in this series</h2>
					

	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;2a649904-5a33-4534-9998-a795011e387a&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/Kinect-to-at-Home-Rehab">Kinect to at Home&#160;Rehab</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/Kinect-to-at-Home-Rehab">
			<img role="img" src="https://f.ch9.ms/thumbnail/61677ffa-b2a0-415b-a447-45657e961e16.png" alt="Kinect to at Home Rehab"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;96a985b6-1602-4dd2-8588-a79c00f6bbe3&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/HoloToolkit-Setup-June-Edition">HoloToolkit Setup - June&#160;Edition</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/HoloToolkit-Setup-June-Edition">
			<img role="img" src="https://f.ch9.ms/thumbnail/5084fb63-182b-4f59-9eb6-a307ab49706e.png" alt="HoloToolkit Setup - June Edition"/>
	</a>
</article>

					<h2>Related episodes</h2>
					

	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;96a985b6-1602-4dd2-8588-a79c00f6bbe3&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/HoloToolkit-Setup-June-Edition">HoloToolkit Setup - June&#160;Edition</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/HoloToolkit-Setup-June-Edition">
			<img role="img" src="https://f.ch9.ms/thumbnail/5084fb63-182b-4f59-9eb6-a307ab49706e.png" alt="HoloToolkit Setup - June Edition"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;d1fee6c1-537f-4012-bca8-a76a01693c1c&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/UrhoSharp-HoloLens">UrhoSharp&#160;HoloLens</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/UrhoSharp-HoloLens">
			<img role="img" src="https://f.ch9.ms/thumbnail/bb202807-528b-4e59-9034-9e004d14e9d0.png" alt="UrhoSharp HoloLens"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;e7f75f9b-a651-4762-acb6-a76a0151c22b&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/HoloLens-Kinect-and-Telepresence">HoloLens, Kinect and&#160;Telepresence</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/HoloLens-Kinect-and-Telepresence">
			<img role="img" src="https://f.ch9.ms/thumbnail/b45517ae-478d-44bf-afb8-71ef9afab01e.png" alt="HoloLens, Kinect and Telepresence"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;af1830f5-ab04-4a2e-a957-a75d012c2992&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/Kinect-to-HoloLens-with-Hololens-Kinect">Kinect to HoloLens with&#160;Hololens-Kinect</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/Kinect-to-HoloLens-with-Hololens-Kinect">
			<img role="img" src="https://f.ch9.ms/thumbnail/ccad587e-4c2a-4525-a310-f56c990e11a3.png" alt="Kinect to HoloLens with Hololens-Kinect"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;be1e98bf-c05f-4b94-80b4-a75601251b6a&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/HoloLens-Terminator-Vision">HoloLens Terminator&#160;Vision</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/HoloLens-Terminator-Vision">
			<img role="img" src="https://f.ch9.ms/thumbnail/e6d510c4-6146-4018-bd58-7f77445da84a.png" alt="HoloLens Terminator Vision"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;61a2ca44-9160-44be-821b-a74801252e6c&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/HoloOCRing">HoloOCR'ing</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/HoloOCRing">
			<img role="img" src="https://f.ch9.ms/thumbnail/731904f3-5643-466f-8e0c-4f7ce71ddc3a.png" alt="HoloOCR&#39;ing"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;72e0658b-d893-4554-beb5-a741010a179c&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/Hello-HoloLens-Emulator">Hello HoloLens&#160;Emulator</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/Hello-HoloLens-Emulator">
			<img role="img" src="https://f.ch9.ms/thumbnail/658e0fce-9d12-447b-ab75-57bf527b2d4b.png" alt="Hello HoloLens Emulator"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;a863a0ec-ea8a-4d85-8651-a71701329f2f&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/Kinect-to-HoloLens-Holograms">Kinect to HoloLens&#160;Holograms</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/Kinect-to-HoloLens-Holograms">
			<img role="img" src="https://f.ch9.ms/thumbnail/ed1193de-dd4e-46f8-a543-5044aab25d32.png" alt="Kinect to HoloLens Holograms"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;9f4ad8a0-258f-4dd1-af84-a6ec01592988&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/kinect">Coding4Fun Kinect&#160;Projects</a>
		</div>
		<h3>
			<a href="/coding4fun/kinect/Project-Infrared-Kinect-and-the-HoloLens">Project-Infrared, Kinect and the&#160;HoloLens</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/kinect/Project-Infrared-Kinect-and-the-HoloLens">
			<img role="img" src="https://f.ch9.ms/thumbnail/ed0c5d16-5d85-47f8-a564-d2aaf2c5d346.png" alt="Project-Infrared, Kinect and the HoloLens"/>
	</a>
</article>


	
<article class="abstract xSmall noVideo" data-api="/Entries(guid&#39;7fcc40a6-4182-44c3-97e5-a6bc014cf879&#39;)/" dir="ltr" lang="en">
	<header>
		<div class="seriesTitle">
			<a href="/coding4fun/blog">Coding4Fun&#160;Blog</a>
		</div>
		<h3>
			<a href="/coding4fun/blog/HoloLens-App-on-a-Raspberry-PI">HoloLens App on a Raspberry&#160;PI?</a>
		</h3>
	</header>

	<a tabindex="-1" class="tile" href="/coding4fun/blog/HoloLens-App-on-a-Raspberry-PI">
			<img role="img" src="https://f.ch9.ms/thumbnail/857768a7-a1da-4c79-b267-c515dd8fa38f.png" alt="HoloLens App on a Raspberry PI?"/>
	</a>
</article>

			</div>
		</div>
	</section>

	<section class="followTheDiscussion">
	
		<div class="container">
			<div class="holder">
				<div class="commentLinks">
				</div>
				<h2>The Discussion</h2>
			
				<ul class="discussion" id="comments">
				</ul>
				
				

						<!-- this form is for not signed in users -->
						<form method="post" id="commentState" class="ch9form discussion episode" autocomplete="off">
							<fieldset id="commentForm">
								<h2>Add Your 2 Cents</h2>
								<ul class="clearfix">
									<li>
										<label class="subject" for="CommentState_Subject">Are you human? If so, leave this field blank.</label>
										<input class="subject" id="CommentState_Subject" name="CommentState.Subject" type="text" value="" />
										<span class="field-validation-valid" data-valmsg-for="CommentState.Subject" data-valmsg-replace="true"></span>
									</li>
									<li>
										<label for="CommentState_AnonymousUser_DisplayName">Name</label>
										<input data-val="true" data-val-regex="Please enter a name with only letters, numbers, and spaces" data-val-regex-pattern="[A-Za-z0-9][A-Za-z 0-9]+[A-Za-z0-9]" data-val-required="Name field is required" id="CommentState_AnonymousUser_DisplayName" name="CommentState.AnonymousUser.DisplayName" type="text" value="" />
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.DisplayName" data-valmsg-replace="true"></span>
									</li>
									<li>
										<label for="CommentState_AnonymousUser_Email">Email</label>
										<input data-val="true" data-val-email="Please enter your email address in the format someone@example.com" data-val-required="Email address is required" id="CommentState_AnonymousUser_Email" name="CommentState.AnonymousUser.Email" type="text" value="" />
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousUser.Email" data-valmsg-replace="true"></span>
									</li>
									<li class="sign-in">
										<span class="conjunction">Or</span>
										<a class="buttonPri" href="https://login.live.com/login.srf?wa=wsignin1.0&amp;rpsnv=13&amp;ct=1499346733&amp;rver=6.7.6626.0&amp;wp=MBI_SSL&amp;wreply=https:%2F%2Fchannel9.msdn.com%2Fcoding4fun%2Fkinect%2FFloating-HoloLens-Screen&amp;id=47159">Sign In</a>
									</li>
									<li>
										<label for="CommentState_AnonymousBody">Comment</label>
										<textarea class="comment" cols="100" data-val="true" data-val-requireone="Comment field is required." data-val-requireone-otherpropertyname="AuthenticatedBody" id="CommentState_AnonymousBody" name="CommentState.AnonymousBody" rows="10">
</textarea>
										<span class="field-validation-valid" data-valmsg-for="CommentState.AnonymousBody" data-valmsg-replace="true"></span>
									</li>
								</ul>
							</fieldset>
							<input name="__RequestVerificationToken" type="hidden" value="eq94nUpiBgJXSvEQw-tIgyeT4UKkqFENEgktc5RG9FLJplpJdV9h-LVwxfFTACI8bscebeowRemwDAnEqxZd5CiBYVw1" />
							<div id="recaptcha"></div>
							<span class="field-validation-valid" data-valmsg-for="Recaptcha" data-valmsg-replace="true"></span>
							<input type="submit" value="Comment" class="buttonPri" disabled="disabled"/>
						</form>
			</div>
		</div>
	
	</section>

</main>



<footer role="contentinfo">
	<div class="container">

		<ul class="sharing">
			<li>
				<a href="/ContactUs" class="email mediumIcon"><span class="screenReader">Email</span></a>
			</li>
			<li>
				<a href="https://twitter.com/ch9" class="twitter mediumIcon"><span class="screenReader">Twitter</span></a>
			</li>
			<li>
				<a href="https://www.facebook.com/msftchannel9" class="facebook mediumIcon"><span class="screenReader">Facebook</span></a>
			</li>
			<li>
				<a href="https://s.ch9.ms/Feeds/RSS" class="rss mediumIcon"><span class="screenReader">RSS</span></a>
			</li>
			<li>
				<a href="https://www.reddit.com/r/ch9" class="reddit mediumIcon">
					<span class="screenReader">RSS</span>
				</a>
			</li>
		</ul>

		<ul class="otherLinks">
			<li>
				<a href="/About">About</a>
			</li>
			<li>
				<a href="/Browse/Authors?direction=desc">Authors</a>
			</li>
			<li>
				<a href="/Events/Speakers?direction=desc">Speakers</a>
			</li>
			<li>
				<a href="/Browse/Tags?letter=A">Tags</a>
			</li>
			<li>
				<a href="/ContactUs">Contact Us</a>
			</li>
			<li>
				<a href="/localization/chrome?returnUrl=%252fcoding4fun%252fkinect%252fFloating-HoloLens-Screen">
					English
				</a>
			</li>
			<li>
				<a href="/CodeOfConduct">Code of Conduct</a>
			</li>
			<li>
				<a href="http://go.microsoft.com/?linkid=4412892">Terms of Service</a>
			</li>
			<li>
				<a href="http://www.microsoft.com/privacystatement/en-us/Channel9App/Default.aspx">Privacy Statement</a>
			</li>
		</ul>

		<p class="copyright">
			&copy; 2017 Microsoft. <wbr>Microsoft reserves all rights associated with the materials on this site.
		</p>
	</div>
</footer>
			
		
		<!-- Host Location: channel9website -->
		<!-- non-realtime scripts. ALL external scripts must be lazy loaded -->
		<!-- Tracking scripts. Social media scripts for facebook, twitter, new relic, web trends -->
			<script src="//tags.tiqcdn.com/utag/msft/ch9/prod/utag.js"></script>
	</body>
</html>